Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

[Python] Problems with module install after upgrade

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Programming
View previous topic :: View next topic  
Author Message
leke
LXF regular


Joined: Mon Oct 22, 2007 6:45 pm
Posts: 503
Location: Oulu, Finland

PostPosted: Mon Feb 20, 2012 7:10 pm    Post subject: [Python] Problems with module install after upgrade Reply with quote

Hi, I recently upgraded my python 2.6 to 2.7, but am having some problems installing modules. I've downloaded the feedparser module and the readme instructed me to have either distutils or setuptools installed (which I have) and then to run "python setup.py install" from the module's root directory.

Here's the error I get...
Code:
asdf@asdf-laptop ~/Desktop/feedparser-5.1 $ python setup.py install
Traceback (most recent call last):
  File "setup.py", line 1, in <module>
    from setuptools import setup
ImportError: No module named setuptools

Any idea how I can get python 2.7 to recognise setuptools or vice versa?

Thanks in advance.
_________________
http://truecenterpublishing.com/zenstory/maybe.html
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8455
Location: Warrington, UK

PostPosted: Mon Feb 20, 2012 11:21 pm    Post subject: Reply with quote

It is possible that setuptools has been installed in the python 2.6 modules directory. Try reinstalling setuptools,and anything else that installed python modules.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
leke
LXF regular


Joined: Mon Oct 22, 2007 6:45 pm
Posts: 503
Location: Oulu, Finland

PostPosted: Tue Feb 21, 2012 7:07 am    Post subject: Reply with quote

Sorry, forgot to mention, I reinstalled setuptools and installed distutils for the first time before I tried to install the module.
I'll google how to check if setuptools is pointing to the correct python version.
_________________
http://truecenterpublishing.com/zenstory/maybe.html
Back to top
View user's profile Send private message
leke
LXF regular


Joined: Mon Oct 22, 2007 6:45 pm
Posts: 503
Location: Oulu, Finland

PostPosted: Tue Feb 21, 2012 7:26 am    Post subject: Reply with quote

Ok, fixed it. I had to run ez_install.py (which pointed setuptools to the correct python version) and afterwards, was able to install the feedparser module without problems.

Thanks for the guidance Wink
_________________
http://truecenterpublishing.com/zenstory/maybe.html
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast