Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Printing from MINT 14 Cinnamon

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Hardware
View previous topic :: View next topic  
Author Message
petlon



Joined: Wed Sep 17, 2008 6:01 pm
Posts: 8

PostPosted: Tue Jan 15, 2013 5:28 pm    Post subject: Printing from MINT 14 Cinnamon Reply with quote

Anybody out there using Mint 14 Cinnamon from the LXF167 DVD and managing to print successfully and reliably?
I have a Samsung ML-2250 laser printer which works well with Mepis 11 and Mint 13. On Mint 14 the printer is recognised and configured automatically and the the first print job works OK. But following jobs result in page after page of blank sheets with the odd hieroglyphic until the paper tray is empty or the printer is switched off at the mains. No instruction from the computer stops the printer and the access_log shows the print job to be successful - see below:

/var/log/cups/access.log
localhost - - [15/Jan/2013:11:36:41 +0000] "POST / HTTP/1.1" 200 360 Create-Printer-Subscription successful-ok
localhost - - [15/Jan/2013:11:40:07 +0000] "POST / HTTP/1.1" 401 244 CUPS-Get-Devices successful-ok
localhost - root [15/Jan/2013:11:40:07 +0000] "POST / HTTP/1.1" 200 1186 CUPS-Get-Devices -
localhost - - [15/Jan/2013:11:40:22 +0000] "POST / HTTP/1.1" 200 4924637 CUPS-Get-PPDs -
localhost - - [15/Jan/2013:11:40:30 +0000] "POST /admin/ HTTP/1.1" 401 358 CUPS-Add-Modify-Printer successful-ok
localhost - root [15/Jan/2013:11:40:30 +0000] "POST /admin/ HTTP/1.1" 200 358 CUPS-Add-Modify-Printer successful-ok
localhost - root [15/Jan/2013:11:40:31 +0000] "POST /admin/ HTTP/1.1" 200 123 Resume-Printer successful-ok
localhost - root [15/Jan/2013:11:40:31 +0000] "POST /admin/ HTTP/1.1" 200 123 CUPS-Accept-Jobs successful-ok
localhost - root [15/Jan/2013:11:40:31 +0000] "POST /admin/ HTTP/1.1" 200 123 CUPS-Set-Default successful-ok
localhost - - [15/Jan/2013:11:42:00 +0000] "POST / HTTP/1.1" 200 183 Renew-Subscription client-error-not-found
localhost - - [15/Jan/2013:11:42:00 +0000] "POST / HTTP/1.1" 200 344 Create-Printer-Subscription successful-ok
localhost - - [15/Jan/2013:11:42:21 +0000] "POST / HTTP/1.1" 200 152 Cancel-Subscription successful-ok
localhost - - [15/Jan/2013:11:42:21 +0000] "POST / HTTP/1.1" 200 152 Cancel-Subscription client-error-not-found
localhost - - [15/Jan/2013:11:43:00 +0000] "POST /printers/ML-2250 HTTP/1.1" 200 12891 Print-Job successful-ok
localhost - - [15/Jan/2013:11:44:13 +0000] "POST /printers/ML-2250 HTTP/1.1" 200 12891 Print-Job successful-ok


/var/log/cups/error_log
E [15/Jan/2013:11:40:23 +0000] [cups-driverd] Bad driver information file "/usr/share/cups/drv/cupsfilters.drv"!
W [15/Jan/2013:11:40:31 +0000] AddProfile failed: org.freedesktop.DBus.Error.UnknownMethod:No such interface `org.freedesktop.ColorManager' on object at path /org/freedesktop/ColorManager/devices/cups_ML_2250


The Mint Forums suggest other people are having printer problems too of various types but none cured it for me. Mint 14 uses systemd and Cups 1.6.1 whilst the older Mint 13 was the old system and Cups 1.5.3. Is this relevant?

Are there any printer gurus that can shed some light on this problem please. Confused

TIA
Back to top
View user's profile Send private message
ferrari
LXF regular


Joined: Tue May 03, 2005 12:09 pm
Posts: 111

PostPosted: Wed Jan 16, 2013 2:31 am    Post subject: Reply with quote

I don't profess to know the definitive cause of the problem here, and it may well be that a bug report should be submitted, but some other thing to try:

1. Have you tried reconfiguring the printer via the CUPS web interface?

http://localhost:631/admin

2. Have you tried a test print from CUPS?

3. Download the latest gutenprint drivers, and try using them

http://gimp-print.sourceforge.net/p_Download.php
Back to top
View user's profile Send private message
petlon



Joined: Wed Sep 17, 2008 6:01 pm
Posts: 8

PostPosted: Fri Jan 18, 2013 12:38 pm    Post subject: Reply with quote

Thanks for reply and ideas. I've tried all the suggestions you made but still with no success. A printer test page will work but then any further printing fails as explained above.

I have tried "live" versions of several other distros such as Ubuntu 12.10, Manjaro, Chakra on LXF DVDs and have found that if Cups v 1.6.1 is used that seems to be the problem.

I've spent hours trying to fix this problem and I'm still going round in circles - very frustrating! So I'll will stay with Mint 13 which does work OK and prints reliably. Perhaps someone will come up with a fix in due course.
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast