KDE's - Network manager no longer works (Solved)

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

KDE's - Network manager no longer works (Solved)

Postby GeordieJedi » Sun Feb 17, 2013 9:04 pm

Hi all.

I've been using Ubuntu 12.04 and KDE on my laptop for a little while now,
and things were running smoothly until about two days ago.

I can login as normal. KDE wallet asks me for my password.
Network manager then "thinks/tries" to connect to my wi-fi network.
It fails, I then get another dialogue box pop up called "Secrets for [Wi-Fi network name]"
I enter the same passowd as KDE wallet (I believe they're part of the same system).

It then thinks about it again, and then fails again.
It's all quite strange.

Is there a config file I can alter/delete to try and get things back to normal ?

(I'm currently posting this from the XFCE DE from the same install, and I can connect fine.
So it looks like its possibly KDE specific ?).

I've also done a bit of Googling and found a couple of related items,
but nothing that stands out that fixes the issue.


Useful info -
OS = Ubuntu 12.04 (LXF coverdisc variant)
DE = (Usually KDE)


TAI for any help or advice.
Last edited by GeordieJedi on Fri Feb 22, 2013 8:24 pm, edited 1 time in total.
User avatar
GeordieJedi
LXF regular
 
Posts: 337
Joined: Thu Jun 14, 2007 10:36 pm
Location: North East England

Postby johnhudson » Sun Feb 17, 2013 9:39 pm

Difficult to tell but the KDE Network Manager should allow you to view/edit any existing connections and let you see whether passwords exist for them. On a recent upgrade I found that all my passwords previously saved with KWallet and available across a series of upgrades had suddenly disappeared from Network Manager and I had to reenter the passwords in Network Manager in order to connect.
johnhudson
LXF regular
 
Posts: 884
Joined: Wed Aug 03, 2005 1:37 pm

Postby caf4926 » Mon Feb 18, 2013 7:17 am

Delete all connection in the NM config
Create New
Be sure to check the box System Connection > add your SSID etc...
CAF4926
User avatar
caf4926
 
Posts: 40
Joined: Mon Dec 26, 2005 6:28 am
Location: The English Lake District

Postby Ram » Mon Feb 18, 2013 8:22 am

Shouldn't you be entering your wifi password not your kde password.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1684
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby caf4926 » Mon Feb 18, 2013 10:45 am

Ram wrote:Shouldn't you be entering your wifi password not your kde password.


It fails, I then get another dialogue box pop up called "Secrets for [Wi-Fi network name]"
I enter the same passowd as KDE wallet (I believe they're part of the same system).


Good point

kwallet password and wifi WPA secret are not the same
CAF4926
User avatar
caf4926
 
Posts: 40
Joined: Mon Dec 26, 2005 6:28 am
Location: The English Lake District

Postby GeordieJedi » Fri Feb 22, 2013 8:17 pm

It's now working properly again.

Thanks to all who responded, much appreciated !!

(And RAM was correct. The "Secrets for Wi-fi network" just needed me to
re-add the Password once again).

I'm guessing that one of the updates had knocked it out.

A nice easy fix (once you know what needs to be done).

Cheers.
User avatar
GeordieJedi
LXF regular
 
Posts: 337
Joined: Thu Jun 14, 2007 10:36 pm
Location: North East England


Return to Help!

Who is online

Users browsing this forum: No registered users and 3 guests