Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Swiss keyboard and GRUB2

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
deMike



Joined: Tue Feb 26, 2013 11:03 am
Posts: 2

PostPosted: Tue Feb 26, 2013 5:50 pm    Post subject: Swiss keyboard and GRUB2 Reply with quote

I installed Mint14/Cinnamon in French on my wife's computer. She has a Logitech K200 Swiss USB keyboard. There are no problems once Linux is running, however when the GRUB menu is displayed the ENTER and UP/DOWN arrows do not work. I cannot select RECOVERY MODE, MEMORY TEST or OTHER OS. I have to wait for the count-down to go to zero which will then start Mint. Similarly, if I boot from an LXF cover disk I can see the menu but can go no further. If I change the keyboard for a US PS/2 keyboard all the keys function and once in Mint my American keyboard is recognised as Swiss, i.e. I type QWERTY and get QWERTZ, so the problem appears to be in GRUB and not Mint. Is there a solution other than having a second keyboard to hand?

Thanks,
Mike
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8464
Location: Warrington, UK

PostPosted: Tue Feb 26, 2013 6:52 pm    Post subject: Reply with quote

The problem is in your BIOS settings. You need to enable the option called "USB legacy mode" or something similar for USB keyboards to work with the BIOS. GRUB uses the BIOS code for this, whereas once the kernel is loaded, its own USB and keyboard handlers are used.

The other keyboard works because it is PS2, this has nothing to do with the language.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
deMike



Joined: Tue Feb 26, 2013 11:03 am
Posts: 2

PostPosted: Tue Feb 26, 2013 7:55 pm    Post subject: Thanks! Reply with quote

Thanks, nelz, for your rapid and very helpful reply. I don't have any USB American keyboards, only PS/2, and was not really able to compare like with like.

Following your suggestion I looked into the BIOS and found:
USB Controller - Enabled
USB 2.0 Controller - Enabled
USB Keyboard Support - Disabled
USB Mouse Support - Disabled
USB Legacy Storage detect - Enabled
I switched the two disabled options to enabled and now everything works OK. Well, almost. In the BIOS the Y key (for Yes) is still in the US position, i.e. the Swiss Z key, but that is no problem.

Many thanks,
Mike
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast