Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Ubuntu laptop internet issues

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
heiowge
LXF regular


Joined: Wed Feb 27, 2008 8:21 pm
Posts: 1901
Location: Cheshire, UK

PostPosted: Mon Mar 25, 2013 7:09 pm    Post subject: Ubuntu laptop internet issues Reply with quote

I've got an old laptop that I've put Ubuntu 12.04 LXF Remix onto (then upgraded to 12.10).

Problem is I have network access via wired and wireless, but no internet.

ping -c 3 followed by the IP for google gives me the expected results. However, if I follow it with www.google.com or www.google.co.uk, I get

ping: unknown host www.google.co.uk

Any ideas? Confused
_________________
i5 4440 3.1Ghz, Asus H87M-E motherboard, 8GB DDR3, 2GB DDR5 nVidia card, 2x500GB Seagate hd, Coolermaster 750W PSU running Mint 16 MATE and Win7

eeepc 1015PX, 1.66 Ghz Intel atom processor, 2 GB DDR3, 320 GB hd, Mint 14 MATE. Fan needs fixing.
Back to top
View user's profile Send private message
Rhakios
Moderator


Joined: Thu Apr 07, 2005 12:18 am
Posts: 7632
Location: Midlands, UK

PostPosted: Mon Mar 25, 2013 9:30 pm    Post subject: Reply with quote

Obviously not getting any nameservers by DHCP. Check /etc/resolv.conf if there's nothing in there then that's likely to be your problem.
The network applet (on which ever desktop you have chosen) should enable you to get nameservers via DHCP or set them manually.
_________________
Bye, Rhakios
Back to top
View user's profile Send private message
mediamgl



Joined: Sat Apr 08, 2006 11:54 pm
Posts: 33

PostPosted: Mon Mar 25, 2013 9:40 pm    Post subject: Re: Ubuntu laptop internet issues Reply with quote

heiowge wrote:

Problem is I have network access via wired and wireless, but no internet.


This happens to me when I start the laptop without it being plugged in to a power supply. If I disable networking, then turn it back on, it again connects to my router, but also the internet works. It never does this when plugged in though; it only happens when first booted from battery.

Not a solution, but at least you are not alone. I haven't checked the Ubuntu forums...
Back to top
View user's profile Send private message
Ram
LXF regular


Joined: Thu Apr 07, 2005 10:44 pm
Posts: 1672
Location: Guisborough

PostPosted: Tue Mar 26, 2013 12:51 am    Post subject: Reply with quote

As Rhakios says DNS issue.

If using Network Manager, have a look at the connection info and see if it lists your IPS Primary / secondary DNS server IPs.

Compare that to your Desktop.

If /etc/resolv.conf is blank on the lappy or doesn't match the desktop, you could copy the file from the desktop to the lappy.
_________________

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
Back to top
View user's profile Send private message MSN Messenger
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast