Resolved - ATEN KVM Switch issue

For discussing Linux compatible (or not) devices

Moderators: ChrisThornett, LXF moderators

Resolved - ATEN KVM Switch issue

Postby Ram » Tue Oct 01, 2013 1:55 am

I've just got a CS64U ATEN KVM USB Switch which isn't playing nicely with Ubuntu LXDE 12.04 - it doesn't recognise the keyboard. That statement isn't strictly true, if I plug the keyboard into the mouse port it works but then the mouse doesn't plugged into the keyboard port.

Works as it should when booting into Windows 7.

lsusb output wired incorrectly :-
Code: Select all
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 030: ID 0557:8021 ATEN International Co., Ltd
Bus 004 Device 031: ID 413c:2010 Dell Computer Corp. Keyboard
Bus 004 Device 032: ID 413c:1003 Dell Computer Corp. Keyboard Hub
Bus 004 Device 033: ID 413c:2010 Dell Computer Corp. Keyboard

lsusb output wired correctly :-
Code: Select all
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 027: ID 0557:8021 ATEN International Co., Ltd
Bus 004 Device 028: ID 413c:2010 Dell Computer Corp. Keyboard
Bus 004 Device 029: ID 1532:000d Razer USA, Ltd


lsusb with the keyboard plugged into the mouse port & the mouse plugged into the keyboard hub, which has both working :-
Code: Select all
Bus 004 Device 064: ID 0557:8021 ATEN International Co., Ltd
Bus 004 Device 065: ID 413c:2010 Dell Computer Corp. Keyboard
Bus 004 Device 066: ID 413c:1003 Dell Computer Corp. Keyboard Hub
Bus 004 Device 067: ID 413c:2010 Dell Computer Corp. Keyboard
Bus 004 Device 068: ID 1532:000d Razer USA, Ltd


Any ideas ?
Last edited by Ram on Fri Oct 04, 2013 6:49 pm, edited 1 time in total.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1675
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby Ram » Thu Oct 03, 2013 9:22 pm

It is now being detected but has the wrong model

Code: Select all
0557:2213 ATEN International Co., Ltd CS682 2-Port USB 2.0 DVI KVM Switch


Also the same when connected to my openSUSE laptop.

Urm, guess it might not be Linux compatible.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1675
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby Rhakios » Fri Oct 04, 2013 5:40 am

The only thing I can tell you is that the CS62U works just fine, oddly it has the same ID as in your original post:

Code: Select all
Bus 001 Device 005: ID 0557:8021 ATEN International Co., Ltd
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Postby Ram » Fri Oct 04, 2013 6:48 pm

Sorted, replaced the keyboard without one without usb ports.

Code: Select all
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 008: ID 0557:8021 ATEN International Co., Ltd
Bus 004 Device 009: ID 0557:2213 ATEN International Co., Ltd CS682 2-Port USB 2.0 DVI KVM Switch
Bus 004 Device 010: ID 1532:000d Razer USA, Ltd


The KVM mouse port can be used has a hub, guess this was conflicting with the hub built into the keyboard.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1675
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby Ram » Fri Oct 04, 2013 6:55 pm

Rhakios wrote:The only thing I can tell you is that the CS62U works just fine, oddly it has the same ID as in your original post:

Code: Select all
Bus 001 Device 005: ID 0557:8021 ATEN International Co., Ltd


This would be company ID I guess.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1675
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby nelz » Fri Oct 04, 2013 8:08 pm

The first four digits are the company ID, the other four are the product ID.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8470
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Ram » Fri Oct 04, 2013 8:27 pm

nelz wrote:The first four digits are the company ID, the other four are the product ID.


That was my initial thought but there isn't a product listed, just the company.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1675
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby nelz » Fri Oct 04, 2013 9:58 pm

Which only means the product is not listed in the hardware ID database on your computer. But you can look it up online

https://usb-ids.gowdy.us/read/UD/0557/8021
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8470
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby Ram » Fri Oct 04, 2013 10:40 pm

Nice link but that is not the same hardware.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1675
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby Rhakios » Sat Oct 05, 2013 3:40 pm

Indeed, it makes me wonder if lsusb is reading the device correctly. I wonder how it works?
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK


Return to Hardware

Who is online

Users browsing this forum: No registered users and 0 guests