Unable to get 3D acceleration working - reason found ?

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Unable to get 3D acceleration working - reason found ?

Postby The Real J. » Thu Jun 09, 2005 6:11 am

I've been having problems getting the 3D acceleration to work on my SuSE 9.0 Personal (using GeForce FX5900). I've done exactly as instructed in the NVidia web page - using YOU to download and install the NVidia graphics driver but the acceleration just won't get enabled. However, after reading the X factor-article on LXF 68 I guess I may have found the reason for that. If I have understood correctly each version of X server requires the correct version of the graphics driver for the 3D acceleration to work so it would seem I've been installing the wrong version each time. IIRC the version of the graphics driver is shown on YOU but how can I find out if it's compatible with my X server version ? Or have I got it all wrong ?

As for using such an old version, I did try installing a later version (first 9.1 Pro, then 9.2 from LXF coverdisc) but both of them had problems with X, giving some X server error, and KDE refused to start so I went back to 9.0 that works fine, although sans 3D acceleration.
The Real J.
 

RE: Unable to get 3D acceleration working - reason found ?

Postby alloydog » Thu Jun 09, 2005 6:46 am

Have you looked in the XF86Config file? It might be that it is not fully enabled there.
You need to unhash GLX & DRI.
User avatar
alloydog
LXF regular
 
Posts: 600
Joined: Thu Apr 07, 2005 7:32 pm

Re: RE: Unable to get 3D acceleration working - reason found

Postby hairymunky » Thu Jun 09, 2005 9:03 am

alloydog wrote:Have you looked in the XF86Config file? It might be that it is not fully enabled there.
You need to unhash GLX & DRI.


Also make sure the graphics driver is "nvidia" instead of the default "nv"

The last time I had suse on my machine, I had to download the drivers through YAST (system updates tab if I can remeber) and that worked fine...
Linux powered Astronomy
User avatar
hairymunky
 
Posts: 59
Joined: Sun Apr 17, 2005 5:50 pm

RE: Re: RE: Unable to get 3D acceleration working - reason f

Postby dth » Thu Jun 09, 2005 11:54 am

It is usually best to download the latest driver from the nvidia website. Then just follow the instructions - as per the readme file. Before you do check YAST to make sure that you have installed the packages: kernel-sources and gcc.
dth
 
Posts: 66
Joined: Thu Apr 07, 2005 4:44 pm

Postby brian » Thu Jun 09, 2005 4:26 pm

I have the same gfx card working with 3D support on suse 9.3 via YOU.

In 9.1(or 9.2) I installed it via YOU without the kernel source installed, and the driver installed "fine"...but it didn't. I'm sure that without the kernel source the package doesn't build therefore no 3D support.

Do you have the kernel source installed?
User avatar
brian
 
Posts: 36
Joined: Thu Apr 07, 2005 6:53 am

Re: RE: Unable to get 3D acceleration working - reason found

Postby The Real J. » Thu Jun 09, 2005 4:47 pm

alloydog wrote:Have you looked in the XF86Config file? It might be that it is not fully enabled there.
You need to unhash GLX & DRI.


Unhash ? You mean remove the commenting # from the beginning ?

The only line containing glx in XF86Config seems to be

Load "glx"

under Section "Module"

As for DRI there is

Section "DRI"
Group "video"
Mode 0660
EndSection

nvidia is selected as the driver under Device section:

Section "Device"
BoardName "GeForce FX 5900"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
EndSection
The Real J.
 

Postby The Real J. » Thu Jun 09, 2005 4:49 pm

brian wrote:I have the same gfx card working with 3D support on suse 9.3 via YOU.

In 9.1(or 9.2) I installed it via YOU without the kernel source installed, and the driver installed "fine"...but it didn't. I'm sure that without the kernel source the package doesn't build therefore no 3D support.

Do you have the kernel source installed?


Yes, I did install the kernel sources when doing the update.
The Real J.
 

Re: RE: Unable to get 3D acceleration working - reason found

Postby alloydog » Thu Jun 09, 2005 5:33 pm

The Real J. wrote:Unhash ? You mean remove the commenting # from the beginning ?

Yes, sorry for dodgy terminology

The Real J. wrote:The only line containing glx in XF86Config seems to be

Load "glx"

under Section "Module"

As for DRI there is

Section "DRI"
Group "video"
Mode 0660
EndSection

Yes, thats the bit I mean:
Code: Select all
Section "Module"
<snip>
# This loads the GLX module
    Load       "glx"
# This loads the DRI module
    Load       "dri"

EndSection

and right at the end:
Code: Select all
 Section "DRI"
#   Mode 0666
EndSection
User avatar
alloydog
LXF regular
 
Posts: 600
Joined: Thu Apr 07, 2005 7:32 pm


Return to Help!

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests