Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Corrupted PDFs of Full issues ?
Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic    Linux Format forums Forum Index -> This Website
View previous topic :: View next topic  
Author Message
mgt6910



Joined: Tue Apr 29, 2008 9:31 pm
Posts: 51
Location: luxembourg

PostPosted: Mon May 04, 2009 9:09 pm    Post subject: RE: No text visible in zipfile of LXF118 Reply with quote

[quote="mgt6910"]I have not received LXF118 by post, so I have dowloaded the zipfile, and I also have no text displayed.

IP.S. I've checked back editions, and I confirm that all editions up to 112 display correctly, and from 113 the text is missing.
Back to top
View user's profile Send private message
mgt6910



Joined: Tue Apr 29, 2008 9:31 pm
Posts: 51
Location: luxembourg

PostPosted: Mon May 04, 2009 10:01 pm    Post subject: RE: No text visible in zipfile of LXF118 Reply with quote

PS: I have checked back issues and I confirm that up to LXF112 displays OK, from 113 the text is absent.
Adobe Reader gives the following information in properties for documents up to 112:
Application : Adobe InDesign CS3 (5.0.2)
PDF Producer: OneVision PDFengine (Build 19.043.R)

From 113, the information is:

Application:
PDF Producer: GPL Ghostscript 8.62

I'll try to change the default PDF reader........
Back to top
View user's profile Send private message
mgt6910



Joined: Tue Apr 29, 2008 9:31 pm
Posts: 51
Location: luxembourg

PostPosted: Tue May 05, 2009 9:54 am    Post subject: RE: No text visible in zipfile of LXF118 Reply with quote

My solution was to install Adobe Reader. All Open Source readers in Fedora 10 have the problem. Perhaps the F10 team don't know about the libpoppler bug ?
Back to top
View user's profile Send private message
IBBoard



Joined: Wed May 17, 2006 10:30 am
Posts: 43

PostPosted: Fri May 29, 2009 8:59 pm    Post subject: RE: No text visible in zipfile of LXF118 Reply with quote

What version of Poppler is Ubuntu using, then? I'm using openSuse 11.1, which apparently has "libpoppler4-0.10.1-1.4" and the PDFs are broken here.
Back to top
View user's profile Send private message Visit poster's website
niki123



Joined: Sat May 30, 2009 10:32 am
Posts: 1

PostPosted: Sat May 30, 2009 10:34 am    Post subject: Re: RE: No text visible in zipfile of LXF118 Reply with quote

IBBoard wrote:
What version of Poppler is Ubuntu using, then? I'm using openSuse 11.1, which apparently has "libpoppler4-0.10.1-1.4" and the PDFs are broken here.


Hi

Your mess was so informative.

___________

<link deleted>
Back to top
View user's profile Send private message
Rhakios
Moderator


Joined: Thu Apr 07, 2005 12:18 am
Posts: 7602
Location: Midlands, UK

PostPosted: Sat May 30, 2009 11:56 am    Post subject: RE: Re: RE: No text visible in zipfile of LXF118 Reply with quote

Hi

Your comment is out of order and your link was spam.
_________________
Bye, Rhakios
Back to top
View user's profile Send private message
IBBoard



Joined: Wed May 17, 2006 10:30 am
Posts: 43

PostPosted: Sat May 30, 2009 1:08 pm    Post subject: RE: Re: RE: No text visible in zipfile of LXF118 Reply with quote

And I object to my post being called a mess Very Happy

I've had a chance to look around now, and it seems like Ubuntu Jaunty is using 0.10.5 - http://packages.ubuntu.com/lt/jaunty/libpoppler4. I'm guessing those few micro versions make a difference.


[edit] Maybe Ubuntu do something weird to their version of libpoppler. I've just installed 0.10.6 from openSuse's X11:common:Factory/openSUSE_11.1 repo (found via the software search) and I'm still getting missing text in the newer PDFs.
Back to top
View user's profile Send private message Visit poster's website
Rhakios
Moderator


Joined: Thu Apr 07, 2005 12:18 am
Posts: 7602
Location: Midlands, UK

PostPosted: Sat May 30, 2009 4:20 pm    Post subject: RE: Re: RE: No text visible in zipfile of LXF118 Reply with quote

I've had a chance to look at this on a system running 11.1 now (I use 11.0 on my main system) and I see the same problem in Okular (KDE4) and KPDF (KDE3), interesting that it doesn't seem to affect previews in Konqueror or Dolphin.
Apart from installing Adobe reader as some have recommended, one other app seems to open the pdfs okay and that's good old KGhostView, which is part of the kdegraphics3-postscript package. I won't try to kid you that its font rendering beautiful, but it does the job, just about.

N.B. I suspect any viewer based on the ghostscript backend will do as well.

Edit: continuing the weirdness, while playing about with Okular, I notice that the Print Preview function shows the full text. Confused
_________________
Bye, Rhakios
Back to top
View user's profile Send private message
IBBoard



Joined: Wed May 17, 2006 10:30 am
Posts: 43

PostPosted: Sat May 30, 2009 6:52 pm    Post subject: RE: Re: RE: No text visible in zipfile of LXF118 Reply with quote

I'm using Gnome, so it's evince that is giving the missing text (but still using poppler as a base). I can't be doing with all of the KDE clutter, even if openSuse is more KDE-centric Smile

I'll install Adobe Reader if I need to, but at the moment I'm mainly archiving the potentially useful PDFs for future reference.
Back to top
View user's profile Send private message Visit poster's website
Rhakios
Moderator


Joined: Thu Apr 07, 2005 12:18 am
Posts: 7602
Location: Midlands, UK

PostPosted: Sat May 30, 2009 7:36 pm    Post subject: RE: Re: RE: No text visible in zipfile of LXF118 Reply with quote

Given that Gnome is the default desktop for SLED, I don't think openSUSE is actually all that KDE-centric. They seem to manage to afford both pretty good support, thankfully still including KDE3.x.
_________________
Bye, Rhakios
Back to top
View user's profile Send private message
IBBoard



Joined: Wed May 17, 2006 10:30 am
Posts: 43

PostPosted: Sat May 30, 2009 7:52 pm    Post subject: RE: Re: RE: No text visible in zipfile of LXF118 Reply with quote

Good point, I guess they have gone more for the middle ground. Back in the 9.x days I think they used to be more KDE-centric, which was why I started with Redhat and stuck with Fedora, but Novell invests in Mono so Gnome makes sense now.

Still, I'd be interested to know what it is that makes poppler handle the files okay on Ubuntu Jaunty but not factory builds of openSuse.
Back to top
View user's profile Send private message Visit poster's website
Borat



Joined: Thu Apr 10, 2008 11:54 pm
Posts: 39
Location: County Antrim, Ireland

PostPosted: Mon Jun 29, 2009 8:06 pm    Post subject: Reply with quote

Just downloaded a libpoppler update via mintupdate tool.

Document Viewer.
Using poppler 0.10.5 (cairo)

Seems like the problem has been fixed. Very Happy
Back to top
View user's profile Send private message
ubuntu



Joined: Tue Jun 15, 2010 4:06 pm
Posts: 43
Location: Midlands, Uk

PostPosted: Mon Jul 19, 2010 4:41 pm    Post subject: corrupt pdfs? Reply with quote

having issues with pdf's too! I'm a new subscriber Razz and i was reading lxf130 and keep getting 'a number is out of range' in adobe reader 9, the file this happens on is lxf130.lxf.pdf. This is extremely annoying so i re-downloaded the file and the same thing again! Sad

Also i have noticed in some editions that there are indeed pages missing such as contents to minor stuff in the back of the mags!

i am using Ubuntu 10.04 and checked the libpoppler and i am using ver 0.12.4 and i don't think this is the problem as the other pdf's display fine so far!

any ideas how to solve this would be very welcome. thanks!
Back to top
View user's profile Send private message
Rhakios
Moderator


Joined: Thu Apr 07, 2005 12:18 am
Posts: 7602
Location: Midlands, UK

PostPosted: Mon Jul 19, 2010 6:29 pm    Post subject: Re: corrupt pdfs? Reply with quote

ubuntu wrote:
having issues with pdf's too! I'm a new subscriber Razz and i was reading lxf130 and keep getting 'a number is out of range' in adobe reader 9, the file this happens on is lxf130.lxf.pdf. This is extremely annoying so i re-downloaded the file and the same thing again! Sad


Adobe Reader is throwing a wobbler with a large variety of pdfs lately, for Windows users I've been recommending Foxit as this doesn't have the same issues (you do need to be careful not to install all the add-ons though).
However if you are using Ubuntu, what's the matter with using Evince or even Okular?
_________________
Bye, Rhakios
Back to top
View user's profile Send private message
ubuntu



Joined: Tue Jun 15, 2010 4:06 pm
Posts: 43
Location: Midlands, Uk

PostPosted: Mon Jul 19, 2010 9:34 pm    Post subject: corrupt pdfs? Reply with quote

there is nothing wrong with Evince or Okular just totaly overlooked them Rolling Eyes So i have taken your advice on evince and noticed the error did not occur so i am now setting this as the default!

i just used reader out of habit...a dirty windows habit so that has to stop!

thanks for the reply Rhakios!!!
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> This Website All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast