Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Wireless on Eee PC 901 doesn't work - Ubuntu 10.04 Beta 2

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
finnux



Joined: Sat Apr 17, 2010 2:27 pm
Posts: 2

PostPosted: Sat Apr 17, 2010 3:02 pm    Post subject: Wireless on Eee PC 901 doesn't work - Ubuntu 10.04 Beta 2 Reply with quote

Hello all,

I have just decided to switch to Ubuntu 10.04 Beta 2 on my Eee PC 901. Everything works fine, except the Eee PC finds my wireless network (WPA2 protection) but can't connect to it. I tried this fix (http://forum.eeebuntu.org/viewtopic.php?f=1&t=2454) that I posted on the Eeebuntu forums and have used for past versions of Ubuntu. When I restarted the Eee though, it couldn't even find my wireless network. There was an error message while installing but I can't remember what it said. The wireless chip is a Ralink RT2860.

Any help would be greatly appreciated,

finnux
Back to top
View user's profile Send private message
PCNetSpec
LXF regular


Joined: Sun Feb 21, 2010 3:50 pm
Posts: 631
Location: Cornwall UK

PostPosted: Sat Apr 17, 2010 6:09 pm    Post subject: Reply with quote

Download the RT2860PCI/mPCI/CB/PCIe(RT2760/RT2790/RT2860/RT2890) drivers from here to your home folder:

2010_01_29_RT2860_Linux_STA_v2.3.0.0.tar.bz2

Start a terminal and install the build-essential and linux-headers packages (if you don't have them already):
Code:
sudo apt-get install build-essential linux-headers-generic


Now, in your home folder untar the Ralink package:
Code:
tar -xvjf 2010_01_29_RT2860_Linux_STA_v2.3.0.0.tar.bz2

you should now have a folder called 2010_01_29_RT2860_Linux_STA_v2.3.0.0 inside you home directory.

Edit the 2010_01_29_RT2860_Linux_STA_v2.3.0.0/os/linux/config.mk file to allow network-manager to manage the card:
Code:
gedit ~/2010_01_29_RT2860_Linux_STA_v2.3.0.0/os/linux/config.mk

find these lines:
Quote:
# Support Wpa_Supplicant
HAS_WPA_SUPPLICANT=n

# Support Native WpaSupplicant for Network Maganger
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=n

and change the 'n' in both lines to 'y' so they now read:
Quote:
# Support Wpa_Supplicant
HAS_WPA_SUPPLICANT=y

# Support Native WpaSupplicant for Network Maganger
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

and save the file.

Now enter the 2010_01_29_RT2860_Linux_STA_v2.3.0.0 directory, compile and install the driver as root:
Code:
cd ~/2010_01_29_RT2860_Linux_STA_v2.3.0.0
sudo su
make && make install

It is important here not to use "sudo" alone, but "sudo su" because with sudo for some reason the installation script fails to create the necessary files and folders.

Now, while still root modprobe the driver module:
Code:
modprobe rt2860sta


Give it a minute to create the ra0 device node, and network manager should now be able to display all visible wireless networks in your area, meanwhile you can stop being root.
Code:
exit


Make sure that ra0 is up and running as it's supposed to:
Code:
iwconfig

and check for a section similar to
Quote:
ra0 RT2860 Wireless ESSID:"" Nickname:"RT2860STA"
Mode:Managed Frequency=2.412 GHz Access Point:
Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off
Link Quality=100/100 Signal level:-29 dBm Noise level:-71 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


Hopefully your wireless card is now working... Use network manager to set your WEP/WPA(2) key, and connect to your network.

To make sure the module is loaded after a reboot, add it to the /etc/modules file:
Code:
sudo echo rt2860sta >> /etc/modules

_________________
WARNING: You are logged into reality as 'root'... logging in as 'insane' is the only safe option.
Linux in the UK
The Linux Community Forum
Back to top
View user's profile Send private message
finnux



Joined: Sat Apr 17, 2010 2:27 pm
Posts: 2

PostPosted: Sat Apr 17, 2010 7:40 pm    Post subject: Reply with quote

Thank you, PCNetSpec! I now have fully-working wifi. Your solution is simple is you copy and paste the code into the terminal.

Thank you again,

Finnux Very Happy
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast