VLC menus in Greek

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

VLC menus in Greek

Postby delboy » Sun Jul 25, 2010 6:11 pm

Hello, I have been using Ubuntu for a couple of years now but this has really confused me! I wanted to edit some videos using VLC but all the menus are in Greek. All other applications are in English. I have used VLC before but not since upgrading to Lucid Lynx 2.6.32-23-generic.
I have completely removed all references to VLC both manually and using Synaptic Package Manager but it always comes back with a Greek menu.
In System -> Administration -> Language Support the only 2 languages selected are English (United Kingdom) and English.
I found on the web the option to add "env LANGUAGE=en" in front of the command "vlc %U" in the properties panel for VLC but this made no difference.
Any help would be much appreciated, thanks.
delboy
 
Posts: 9
Joined: Fri Sep 26, 2008 5:46 pm

Postby PCNetSpec » Sun Jul 25, 2010 8:07 pm

Works for me on VLC 1.0.2 (Goldeneye) with the command(s):
for english
Code: Select all
env LANGUAGE=en vlc

or for french
Code: Select all
env LANGUAGE=fr vlc

or german
Code: Select all
env LANGUAGE=de vlc


so try launching from a terminal.
WARNING: You are logged into reality as 'root'... logging in as 'insane' is the only safe option.
Linux in the UK
The Linux Community Forum
User avatar
PCNetSpec
LXF regular
 
Posts: 631
Joined: Sun Feb 21, 2010 3:50 pm
Location: Cornwall UK

Postby Rhakios » Sun Jul 25, 2010 8:41 pm

On the other hand, uninstalling and re-installing does not touch any configuration in your home directory. You will find configuration parameters for vlc in .config/vlc - try removing that before running vlc again.
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

VLC in Greek

Postby delboy » Mon Jul 26, 2010 7:51 pm

Hello people, thanks for your suggestions; however neither one solves the problem. I removed .config/vlc and it was remade when I ran VLC again but it was still in Greek.
To PCNetSpec, when you say launch in terminal what exactly do you mean?
Hope to hear from you soon
Thanks and regards,
delboy
delboy
 
Posts: 9
Joined: Fri Sep 26, 2008 5:46 pm

Postby PCNetSpec » Mon Jul 26, 2010 8:06 pm

Open a terminal (Applications > Accessories > Terminal), and type:
Code: Select all
env LANGUAGE=en vlc

hit enter. (remember Linux commands ARE case sensitive)
VLC *should* start in english
WARNING: You are logged into reality as 'root'... logging in as 'insane' is the only safe option.
Linux in the UK
The Linux Community Forum
User avatar
PCNetSpec
LXF regular
 
Posts: 631
Joined: Sun Feb 21, 2010 3:50 pm
Location: Cornwall UK

Postby Rhakios » Mon Jul 26, 2010 8:21 pm

Having found what I presume is the only other instance of this on the 'net, I see that the OP there states that the menus are not actually in Greek, but just have Greek characters where one would normally expect Latin ones.
This suggests that it's a font problem rather than a language one.
In System>Preferences>Appearance>Fonts try changing the Application font. I'm using DejaVu Sans Book (10) which I find clear enough.
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Postby PCNetSpec » Mon Jul 26, 2010 9:27 pm

Aah, yes I remember someone having a similar problem with OpenOffice... restoring fonts to default fixed the problem.
WARNING: You are logged into reality as 'root'... logging in as 'insane' is the only safe option.
Linux in the UK
The Linux Community Forum
User avatar
PCNetSpec
LXF regular
 
Posts: 631
Joined: Sun Feb 21, 2010 3:50 pm
Location: Cornwall UK

VLC in Greek

Postby delboy » Tue Jul 27, 2010 7:07 am

Hello Khakios, that did it !! I changed the font to Comic sans and all is well.
Thanks very much .
Best regards,
delboy
delboy
 
Posts: 9
Joined: Fri Sep 26, 2008 5:46 pm

Re: VLC in Greek

Postby Rhakios » Tue Jul 27, 2010 5:05 pm

delboy wrote:I changed the font to Comic sans and all is well.


That's the first time I've heard anyone say that about Comic Sans :lol:
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Re: VLC in Greek

Postby towy71 » Tue Jul 27, 2010 6:50 pm

delboy wrote:Hello Khakios
Khakios lol,
delboy wrote:changed the font to Comic sans and all is well.delboy
Using Comic sans #fail :P
still looking for that door into summer
User avatar
towy71
Moderator
 
Posts: 4264
Joined: Wed Apr 06, 2005 2:11 pm
Location: wild West Wales


Return to Help!

Who is online

Users browsing this forum: No registered users and 0 guests