Important - FreeBSD Tutorial (LXF136)

Comments, suggestions and questions about Linux Format magazine and the coverdiscs

Moderators: ChrisThornett, LXF moderators

Important - FreeBSD Tutorial (LXF136)

Postby bob_moss » Sat Aug 14, 2010 5:18 pm

There are a number of omissions in the final stages of this tutorial that will cause errors with your BSD setup. I've only just seen the print copy myself, so have posted this asap.

Issue 1: Non-functioning Gnome
After the following code:
Code: Select all
pkg_add -r gnome2

you MUST type the following line:
Code: Select all
pkg_add -r gnome2-fifth-toe


Without the second line Gnome will consist of a login screen and not very much else.

Issue 2: Gnome doesn't launch
You need to create a file called '.xinitrc' in your home directory and add the following line to it:
Code: Select all
exec ck-launch-session gnome-session

Without this file X Server will never launch Gnome, however hard you try to coax it.

Issue 3: X Server errors
There is a known issue in some versions of FreeBSD where X Server crashes when you launch Gnome. The work-around for this is:
Code: Select all
ln -s /usr/local/lib/libintl.so.8 /usr/local/lib/libintl.so.9
pkg_add -r portupgrade


It is only after completing that stage that should you proceed to add
Code: Select all
gnome_enable='YES'

to /etc/rc.conf.

The tutorial is called 'Hardcore' for a reason - these issues aren't ones that an experienced Linux user couldn't Google solutions for. However, I have provided them here in order to ensure that the solutions are in an easy to find place.
Bob Moss writes for LXF and is studying computer science at the University of Plymouth, UK

Linux Registered User #473630
User avatar
bob_moss
 
Posts: 73
Joined: Thu May 08, 2008 9:47 am
Location: Wiltshire, UK

Postby zzak » Thu Sep 16, 2010 11:51 pm

If you use gnome_enable="YES"
You cannot use "exec ck-launch-session gnome-session"
This command is used if you do not use GDM which is enabled
by gnome_enable="YES"

Instead, in your ~/.xinitrc file, use "exec gnome-session"
zzak
 
Posts: 1
Joined: Thu Sep 16, 2010 11:42 pm
Location: Canada

Postby bob_moss » Mon Oct 11, 2010 11:48 pm

Thank you for the correction! I had missed this while typing up the solution.
Bob Moss writes for LXF and is studying computer science at the University of Plymouth, UK

Linux Registered User #473630
User avatar
bob_moss
 
Posts: 73
Joined: Thu May 08, 2008 9:47 am
Location: Wiltshire, UK


Return to Magazine and coverdiscs

Who is online

Users browsing this forum: No registered users and 0 guests

cron