Fedora Core 3 & Samba

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Fedora Core 3 & Samba

Postby crussell » Tue Apr 19, 2005 8:39 pm

Help. Help. Help.

SO, I got FC3 installed and everything's running like a dream ... except for Samba ..

It's installed OK, it's running on the Linux box and I can see the linux box from Network Neighbourhood on my XP Pro PC, but when I click on the FC3 box in Network Neighbourhood I donlt see any of the shared directories on the linux box - in fact file explorer just shows blank. I know the shared directories exist on the FC box and I know there are files them, so can anyone help shed any light on why they might not be showing up ?

TIA

Chris
crussell
 

RE: Fedora Core 3 & Samba

Postby Nigel » Wed Apr 20, 2005 3:00 pm

The usual reason is that your XP username isn't set up on the Samba box... try running SWAT (Samba remote administration - just point your browser at http://localhost:901 on your Fedora box) and making sure that the username and password you use on the XP box has been set.
Hope this helps,

Nigel.
User avatar
Nigel
LXF regular
 
Posts: 1141
Joined: Fri Apr 08, 2005 8:03 pm
Location: Gloucestershire, UK

Postby Andy » Wed Apr 20, 2005 6:22 pm

Hi Chris,

You can actually do this very easily if you don't use SWAT :)

Basically there are a couple of things you need to make sure you have switched on. First of all, if you are using a firewall on your FC3 computer you need to open up the ports for Samba, which are ports 135-139. You do this by going to the Security Level option and clicking on the firewall tab. In the other ports box the correct syntax is:

Code: Select all
135:tcp, 136:tcp 137:tcp, 138:tcp, 139:tcp


Click OK and your firewall will be ready for Samba.

Next go to a command prompt (user or root) and type

Code: Select all
rpm -q system-config-samba


to find out if you have the Fedora Samba Configuration interface. If not, use

Code: Select all
yum install system-config-samba


to download and install it.

Under system settings you should see another sub-menu which should contain a Samba option. Click this to bring up FC's Samba config tool. Check to see that your folder is listed and select it with a single click. Click edit and make sure that Is VIsible and is Writeable are checked. Go to users and select available to all users (unless you have already created a Samba account this is the best way). Click OK and then exit the Samba config tool.

You should now be able to access the share across the network!

Let me know if this doesn't work and I'll try something else for you.

Andy
User avatar
Andy
 
Posts: 90
Joined: Mon Apr 04, 2005 5:29 pm
Location: Trowbridge


Return to Help!

Who is online

Users browsing this forum: Bing [Bot] and 1 guest