Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Important - FreeBSD Tutorial (LXF136)

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Magazine and coverdiscs
View previous topic :: View next topic  
Author Message
bob_moss



Joined: Thu May 08, 2008 10:47 am
Posts: 73
Location: Wiltshire, UK

PostPosted: Sat Aug 14, 2010 6:18 pm    Post subject: Important - FreeBSD Tutorial (LXF136) Reply with quote

There are a number of omissions in the final stages of this tutorial that will cause errors with your BSD setup. I've only just seen the print copy myself, so have posted this asap.

Issue 1: Non-functioning Gnome
After the following code:
Code:
pkg_add -r gnome2

you MUST type the following line:
Code:
pkg_add -r gnome2-fifth-toe


Without the second line Gnome will consist of a login screen and not very much else.

Issue 2: Gnome doesn't launch
You need to create a file called '.xinitrc' in your home directory and add the following line to it:
Code:
exec ck-launch-session gnome-session

Without this file X Server will never launch Gnome, however hard you try to coax it.

Issue 3: X Server errors
There is a known issue in some versions of FreeBSD where X Server crashes when you launch Gnome. The work-around for this is:
Code:
ln -s /usr/local/lib/libintl.so.8 /usr/local/lib/libintl.so.9
pkg_add -r portupgrade


It is only after completing that stage that should you proceed to add
Code:
gnome_enable='YES'

to /etc/rc.conf.

The tutorial is called 'Hardcore' for a reason - these issues aren't ones that an experienced Linux user couldn't Google solutions for. However, I have provided them here in order to ensure that the solutions are in an easy to find place.
_________________
Bob Moss writes for LXF and is studying computer science at the University of Plymouth, UK

Linux Registered User #473630
Back to top
View user's profile Send private message Send e-mail
zzak



Joined: Fri Sep 17, 2010 12:42 am
Posts: 1
Location: Canada

PostPosted: Fri Sep 17, 2010 12:51 am    Post subject: Reply with quote

If you use gnome_enable="YES"
You cannot use "exec ck-launch-session gnome-session"
This command is used if you do not use GDM which is enabled
by gnome_enable="YES"

Instead, in your ~/.xinitrc file, use "exec gnome-session"
Back to top
View user's profile Send private message
bob_moss



Joined: Thu May 08, 2008 10:47 am
Posts: 73
Location: Wiltshire, UK

PostPosted: Tue Oct 12, 2010 12:48 am    Post subject: Reply with quote

Thank you for the correction! I had missed this while typing up the solution.
_________________
Bob Moss writes for LXF and is studying computer science at the University of Plymouth, UK

Linux Registered User #473630
Back to top
View user's profile Send private message Send e-mail
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Magazine and coverdiscs All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast