Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Compatibility Issues - Ubuntu 10.04 & graphics accelerat

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Hardware
View previous topic :: View next topic  
Author Message
Unmenschenable



Joined: Tue Sep 14, 2010 10:12 pm
Posts: 2
Location: Near Seattle

PostPosted: Tue Sep 14, 2010 10:20 pm    Post subject: Compatibility Issues - Ubuntu 10.04 & graphics accelerat Reply with quote

My problem started with a jumping cursor and randomly selecting text in e-mail and spreadsheets. Actually, it happens with scratch pad, as well as mouse. Using the arrow keys sometimes gets me out of it, but the eventual outcome is a total freeze. When it freezes, I often lose files. I'm guessing that I might have a compatibility issue between Ubuntu 10.04 & the graphics accelerator on the laptop motherboard. Could someone help me confirm that's the case and what I might do about it?

Let me sum up more technical background: I have a dual install of Ubuntu 10.04 and Win7 on a new Toshiba L505 laptop with a Pentium processor (64-bit OS for both). This system features a 4500 MHD graphics media accelerator incorporated on the motherboard. Using the “lspci | grep VGA” command, I got more on the chipset as follows: “00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)”.

This still might not be enough info on the chipset. I understand that some issues exist with i845, i855 and other 8xx Intel chips (https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes). Could someone help me confirm what my chipset would be? Some online literature indicates that my T4400 Pentium Dual Core might use the GL40 chipset.

So, what might I do to mitigate, if I indeed have a compatibility problem?

Any help would be greatly appreciated.
Back to top
View user's profile Send private message
ollie
Moderator


Joined: Mon Jul 25, 2005 12:26 pm
Posts: 2749
Location: Bathurst NSW Australia

PostPosted: Mon Sep 20, 2010 12:25 am    Post subject: Reply with quote

There are plenty of reports of problems with various Intel graphics chips. There is also a couple of PPA specifically for the latest Intel graphics driver. I haven't tried these (I make sure that I have nVidia chipsets in everything Wink ) but you should be able to get better performance for your laptop, which hopefully fixes the problems.
Back to top
View user's profile Send private message
Unmenschenable



Joined: Tue Sep 14, 2010 10:12 pm
Posts: 2
Location: Near Seattle

PostPosted: Tue Sep 21, 2010 7:48 pm    Post subject: Reply with quote

Thanks for the reply Ollie. I understood the merits of the nVidia chipset before I bought the Toshiba, but as what I do isn't graphics intensive, that item dropped out of my list of considerations in finding an affordable laptop. Now updating the driver might fix the problem, but I'm not sure.

Before I jump, here's some more musings. On the Win7 side of the partition, I determined that I have the Intel “embedded” graphics driver version 8.15.10.1883. “Embedded” might refer to the fact that it's for a graphics accelerator on the motherboard (that's a SWAG). I had to go to the Windows side, as Ubuntu detects no proprietary drivers. I can possibly assume that Ubuntu uses the same driver.

On the Intel download site, I find a driver update for Linux dated 8-24-10 with no version listed. The penultimately released version was 9.0.2, dated 8-8-08. This driver is specific to my 4 Series Express Chipset. They call it an Intel Embedded Graphics Drivers (IEGD) for VBIOS.

Ollie, one of your links is specific to the GMA500. I do indeed have a graphics media accelerator on the motherboard, but the question is, which one? I found a chart on a wikipedia site for the Intel GMA, but I'm having trouble matching accelerator with chipset. Would anyone have any slick way of determining my accelerator?

I'd like to learn a little more before updating the driver.
Back to top
View user's profile Send private message
ollie
Moderator


Joined: Mon Jul 25, 2005 12:26 pm
Posts: 2749
Location: Bathurst NSW Australia

PostPosted: Wed Oct 06, 2010 10:10 am    Post subject: Reply with quote

Unmenschenable wrote:
I can possibly assume that Ubuntu uses the same driver.


Ubuntu will not use the Windows graphics driver.

Unmenschenable wrote:
On the Intel download site, I find a driver update for Linux dated 8-24-10 with no version listed. The penultimate released version was 9.0.2, dated 8-8-08. This driver is specific to my 4 Series Express Chipset. They call it an Intel Embedded Graphics Drivers (IEGD) for VBIOS.

Ollie, one of your links is specific to the GMA500. I do indeed have a graphics media accelerator on the motherboard, but the question is, which one? I found a chart on a wikipedia site for the Intel GMA, but I'm having trouble matching accelerator with chipset. Would anyone have any slick way of determining my accelerator?

I'd like to learn a little more before updating the driver.


I did a bit of Googling for the laptop you mentioned and the hardware for that laptop. You should be able to use the latest Intel driver from the first link, but if that doesn't work the GMA500 driver in the second link should work with the hardware you have.

I can't try either of them so you should try both and see which one gives you the best performance.
Back to top
View user's profile Send private message
RedWillow
LXF regular


Joined: Thu May 29, 2008 2:05 pm
Posts: 719

PostPosted: Wed Oct 06, 2010 12:25 pm    Post subject: Re: Compatibility Issues - Ubuntu 10.04 & graphics accel Reply with quote

Unmenschenable wrote:
Using the “lspci | grep VGA” command, I got more on the chipset as follows: “00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)”.


On my Sony Vaio laptop, I get:

Code:
lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)


Identical to yours. I get no such issues as you are experiencing in Ubuntu 10.04. Nor in 10.10, nor in either 9.04 and 9.10 when I was running them. So we can assume that the default Intel video driver is unlikely to be the problem here.

This is only an impression, but I get the sense that Toshibas give more than their fair share of problems with Linux from what I read on Ubuntuforums. Of course, you have to take a lot of what gets posted on Ubuntuforums with a salt-mine full of salt, but I wonder if it's worth looking at something like ACPI implementation in Toshiba.

Although this Ubuntu community page specifically addresses live CD booting, it does say:

Quote:
Changing the boot command may be necessary to fix problems with system freezes or video displays when trying to install Ubuntu.


So trying some of the boot options listed there might help.
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast