Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

PHP Coding Academy Project 4 - missing something?

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Programming
View previous topic :: View next topic  
Author Message
CaptainPasty



Joined: Sat Aug 28, 2010 11:00 am
Posts: 5
Location: Manchester

PostPosted: Sat Oct 09, 2010 11:21 pm    Post subject: PHP Coding Academy Project 4 - missing something? Reply with quote

Hi all,

Finally made it to the last project in the mini book but seem to have hit a snag. MySQL seems to be doing everything it should and I've created the "testing" database with no problems, but when I get as far as running project4.php in my browser I get a blank page. I've taken out the PHP bit and run it with just the HTML code and it displays the forms correctly, so I'm assuming I've either missed something in the PHP section or my setup might be missing something (this happened in another post I made for a problem I had in Project 3). Would anybody mind having a look over my code and checking that I'm not missing anything in it? If all looks ok any suggestions would be great:

<?php
//change "password" to your MySQL password!
mysql_connect("localhost","root","anyoldpassword");
mysql_select_db("testing");
?>

<h1>Add new task</h1>
<form method="post" action="project4.php">
<p>Name it:<input type="text" name="task_name"/></p>
<p>Describe it:<input type="text" name="task_description"/></p>
<input type="submit" value="Add"/>
</form>


Thanks in advance
Back to top
View user's profile Send private message
CaptainPasty



Joined: Sat Aug 28, 2010 11:00 am
Posts: 5
Location: Manchester

PostPosted: Sun Oct 10, 2010 11:23 am    Post subject: Nevermind... Reply with quote

Started up my netbook this morning and it's working fine. I think I must have added or replaced some SQL component before I started and forgot to reset...Doh.
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast