virtualbox win7

Help and discussion about non-Linux operating systems

Moderators: ChrisThornett, LXF moderators

virtualbox win7

Postby heiowge » Mon Mar 07, 2011 4:04 pm

I just installed win7 on my virtualbox setup. I put on the guest additions, but there's a few bits I've forgotten how to do and one bit I haven't faced before...

1) 32 bit win7 ultimate running on 64 bit ubuntu 10.10, given 1.5 GB RAM to play with. For some reason the desktop reverts to win 7 basic.

2) My shared files seem to be read only. I might have set up the sharing wrong. A few pointers please? :oops:
User avatar
heiowge
LXF regular
 
Posts: 1905
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby bobthebob1234 » Mon Mar 07, 2011 5:10 pm

1: Have you played with Video memory or enabled 3d / 2d Acceleration?

2: Well I never got them to work so you are further than me!
For certain you have to be lost to find the places that can't be found. Elseways, everyone would know where it was
User avatar
bobthebob1234
LXF regular
 
Posts: 1370
Joined: Thu Jan 03, 2008 9:38 pm
Location: A hole in a field

Re: virtualbox win7

Postby ollie » Wed Mar 09, 2011 11:09 pm

heiowge wrote:1) 32 bit win7 ultimate running on 64 bit ubuntu 10.10, given 1.5 GB RAM to play with. For some reason the desktop reverts to win 7 basic.


3D support in VirtualBox is "experimental". Windows 7 detects a VESA compatible graphics card and sets the graphical environment appropriately. See here.

heiowge wrote:2) My shared files seem to be read only. I might have set up the sharing wrong. A few pointers please? :oops:


Check the user details that you are using when connecting to the shared folders. It is definitely just a permissions issue.
User avatar
ollie
Moderator
 
Posts: 2749
Joined: Mon Jul 25, 2005 11:26 am
Location: Bathurst NSW Australia

Re: virtualbox win7

Postby heiowge » Thu Mar 10, 2011 12:58 am

ollie wrote:Check the user details that you are using when connecting to the shared folders. It is definitely just a permissions issue.


Yeah, that's how I fixed it last time. I just can't remember exactly how. I had to add something like samba to a group somewhere...
User avatar
heiowge
LXF regular
 
Posts: 1905
Joined: Wed Feb 27, 2008 8:21 pm
Location: Cheshire, UK

Postby PCNetSpec » Thu Mar 10, 2011 2:41 am

AFAIK there is no way to get the Win7 Aero interface to work in Virtualbox, but if you find a way I'd be interested.

As for the shared folders... if you mean the folders shared between the Linux host and the Win7 guest...

In Linux, go to the folder(s) that are being shared, right-click on them, and select "Properties", then select the "Shared" tab, then put a tick in:

Allow others to create and delete files in this folder.

and click "Update Shares"
(it may prompt you to install samba, but should offer to do it for you)

Now you will probably have to reboot Linux for the changes to be applied, or restart samba.

Now in the Win7 VM click on the share to access it, and enter your Linux login credentials... you can tell it to remember these if you wish.
WARNING: You are logged into reality as 'root'... logging in as 'insane' is the only safe option.
Linux in the UK
The Linux Community Forum
User avatar
PCNetSpec
LXF regular
 
Posts: 631
Joined: Sun Feb 21, 2010 3:50 pm
Location: Cornwall UK


Return to Other OS

Who is online

Users browsing this forum: No registered users and 1 guest