Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Netbook can't resume after upgrade to ubuntu 10.10

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
daudi



Joined: Sat Dec 16, 2006 11:00 pm
Posts: 59
Location: Maidstone, Kent, UK

PostPosted: Mon Mar 07, 2011 7:56 pm    Post subject: Netbook can't resume after upgrade to ubuntu 10.10 Reply with quote

Hi,

My samsung n230 used to be perfect. I had ubuntu 10.04 Lucid Lynx and never rebooted it. I could close the lid and it would go into sleep mode, and when I opened it again I had the log in screen in 4 seconds. In practical terms this was close to instant-on. It was perfect.

Then I upgraded to 10.10, which is indeed a maverick OS. Resume after sleep does not work and is probably this bug:
https://bugs.launchpad.net/ubuntu/+source/uswsusp/+bug/658755
It seems to have been pushed somewhere and I am not sure if anyone is working on it.

Right now my only option seems to be to wait for 11.04 and hope that this will fix it.

Anyone got any idea how I might work around this now? How easy would it be to down grade to 10.04?

Thanks.
Back to top
View user's profile Send private message
PCNetSpec
LXF regular


Joined: Sun Feb 21, 2010 3:50 pm
Posts: 631
Location: Cornwall UK

PostPosted: Mon Mar 07, 2011 9:04 pm    Post subject: Reply with quote

Try adding:

intel_idle.max_cstate=0

as a kernel boot parameter.

Further info:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/640100?comments=all

Comments #115 onwards.

BTW, from that bug report, it seems 11.04 still has the same issue.

Instructions...

1.) Edit the /etc/default/grub file... in a terminal enter:
Code:
sudo gedit /etc/default/grub


2.) Find the line:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
and change it to:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=0"

3.) Save and exit gedit.

4.) Now update GRUB... back in the terminal enter:
Code:
sudo update-grub


5.) Reboot.

Also read comment #129 (onwards) on the above link.
_________________
WARNING: You are logged into reality as 'root'... logging in as 'insane' is the only safe option.
Linux in the UK
The Linux Community Forum
Back to top
View user's profile Send private message
daudi



Joined: Sat Dec 16, 2006 11:00 pm
Posts: 59
Location: Maidstone, Kent, UK

PostPosted: Tue Mar 08, 2011 6:08 pm    Post subject: Reply with quote

Thank you very much indeed! This solves the problem. The link you provided was very informative. Thanks again.
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast