Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

login fails after upgrade

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
delboy



Joined: Fri Sep 26, 2008 6:46 pm
Posts: 9

PostPosted: Wed May 30, 2012 10:15 am    Post subject: login fails after upgrade Reply with quote

I was running Ubuntu 11.10 without any problems and I decided to upgrade over the internet to 12.04. All appeared to go well and I eventually got my desktop back with the latest version installed.
I then did a reboot.
The standard window appeared asking for my password; entered password, the screen went black briefly with a few lines of white text then password screen reappeared.
If I use 'ctrl+alt+F1' I can log in to text mode ok.
I have done the following without success: changed my password, just in case: changed display manager to gdm; removed /.Xauthority: removed X0-lock file: updated nVidia drivers: added repository 'ppa.launchpad.net/mterry/ppa2/ubuntu and done update: 'startx' gives 'fatal server error, server already active for display 0 .... invalid MIT-MAGIC-COOKIE -1, key invalid.
My system is : Athlon 64 (x2) 4200 with 2GB RAM,a Radeon X1800XT video card and 100GB hard disk.
I have spent a lot of time getting my desktop the way I like it and I would like to get it back!
Any help would be greatly appreciated.
Thanks
Back to top
View user's profile Send private message
nordle
LXF regular


Joined: Fri Apr 08, 2005 10:56 pm
Posts: 1500

PostPosted: Wed May 30, 2012 9:50 pm    Post subject: Reply with quote

I had the same issue with 11.10, but you did not.

Eve worse, with 12.04. I'd enter the password, it would do nothing after pressing enter.
The only way round this was to alt+F2 to another terminal, log in via text, sudo service lightdm restart, then login via graphical method. Then wash, rinse, repeat 2-3 times. Eventually getting a desktop.

Updating to nvidia-post-release updates fixed this.....sort of. Now I'm back to having to enter my password twice at the lightdm login, but at least its consistent in letting me login on the 2nd attempt each time, without having to restart the lightdm service.

Sorry, no solutions from me to your issue.
_________________
I think, therefore I compile
Back to top
View user's profile Send private message
Ram
LXF regular


Joined: Thu Apr 07, 2005 10:44 pm
Posts: 1668
Location: Guisborough

PostPosted: Wed May 30, 2012 11:38 pm    Post subject: Reply with quote

Could be as simple as your GUI login is using one language say American and your text login using GB.

If your using special characters in your password such as , you'll get # etc.

As your GUI screen goes black then displays text, it could be that it's not able to display the failed authentication password box of a wrongly entered password.
_________________

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
Back to top
View user's profile Send private message MSN Messenger
delboy



Joined: Fri Sep 26, 2008 6:46 pm
Posts: 9

PostPosted: Thu May 31, 2012 10:30 am    Post subject: Reply with quote

Hello nordle, tried your first suggestion; no luck I'm afraid! Also updating nvidia didnt help either, but thanks for your response.

Hello Ram, I'm not using any special characters for my login. If I enter a wrong password the screen says "invalid password ". I also changed my password from a text login just in case. I can login in when in text mode so the password must be ok?
Also , thanks for your reply
Back to top
View user's profile Send private message
delboy



Joined: Fri Sep 26, 2008 6:46 pm
Posts: 9

PostPosted: Tue Jun 26, 2012 10:30 am    Post subject: login fails after update Reply with quote

Hello everyone,
eventually I did "apt-get update" and all works now. I did this after contacting MGLUG.
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast