Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CUPs problem

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
paulm
LXF regular


Joined: Mon Apr 03, 2006 5:53 am
Posts: 242
Location: Oxfordshire, UK

PostPosted: Tue Jul 24, 2012 8:42 pm    Post subject: CUPs problem Reply with quote

I have a Brother laser printer, attached to an (old) Amahi server, and set as a shared printer. Since I (very occasionally) have Windows machines on my network, I've got is set as a Samba share.

All works pretty well. with one exception. In most instances, CUPS picks up the printer automatically on other machines on the network. Which is fine, except I then cannot adjust any of the printer defaults from a network machine. If I select the printer, then go to Administration and select modify printer defaults, I get a "403 Forbidden" error. I have no opportunity to log in, and no way I can find to get access to set the printer defaults that I need. I can print, but that is it...

If I manually add the printer, I have to log in to CUPS as root to do so. And once I've done that, I can modify printer defaults both when I create the printer, and later (without having to log in to CUPS).

So, what am I missing? Its useful to have the printer autodetected and added to the CUPS setup, but its a pain not being able to set or change the printer settings once it has been autodetected. Is there any alternative to manually adding the printer to every other machine on the network?

Paul.
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8464
Location: Warrington, UK

PostPosted: Tue Jul 24, 2012 10:10 pm    Post subject: Reply with quote

Is this error coming from the CUPS web interface? If so, the config is probably set to allow only access to the admin pages from the local machine. Find the section in /etc/cups/cupsd.conf that starts with

Code:
<Location /admin>


and add this before the next </Location> line

Code:
Allow localhost
Allow 192.168.1.* 


Change the second line to suit your network addressing. Repeat this for the <Location /admin/conf> section, then restart cupsd.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
paulm
LXF regular


Joined: Mon Apr 03, 2006 5:53 am
Posts: 242
Location: Oxfordshire, UK

PostPosted: Sun Jul 29, 2012 4:45 pm    Post subject: Reply with quote

Thanks. That did it.

I don't understand why, if I add the printer manually, I can change the defaults - the problem only occurred when the printer was autodetected?

Smile Anyhow, I'll remember those defaults when I finally get round to retiring the Amahi box and replacing it with my own Arch-derived server....

Paul.
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast