Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Lyx 2.0 spellchecker

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
fede



Joined: Thu Sep 01, 2005 4:23 am
Posts: 56

PostPosted: Tue Aug 07, 2012 10:33 pm    Post subject: Lyx 2.0 spellchecker Reply with quote

I read with enthisiasm the answer to the query "Enchanting Lyx" in LXF 161 Answers section. I run Lyx on a bunch of different computers, three of them running version 2.0.0, and one of them seems unable to activate a spellchecker, while the other two do fine. The rogue computer, and one of the good ones, runs Ubuntu 12.04 (the "bad" is using a KDE desktop, while the "good" uses LXDE).

I created the (missing) ~/.enchant directory, and the enchant.ordering file. Enchant is installed, of course, as well as aspell, ispell, and hunspell. That didn't work, so I dwelved in the configuration files for Lyx, hand editing the "preferences" file so it would match the spellechecker instruction in the "good" system, but that didn't work either. I did try to "Reconfigure" every time I chnaged somehting, but nothing changed.

By the way, any attempt to activate the spellchecker from within Lyx fails, since the "spellchecker engine" entry in the Tools > Preferences > Language Settings > Spellchecker is grayed out, and no cicking brings it up.

ANy suggestion would be greatly appreciated - I can move my files to a "good" sytem for spellchecking purposes, but it is a pain...
Back to top
View user's profile Send private message
johnhudson
LXF regular


Joined: Wed Aug 03, 2005 2:37 pm
Posts: 870

PostPosted: Wed Aug 08, 2012 10:08 pm    Post subject: Reply with quote

Enchant is only intended for use if you have no myspell (i.e. LibreOffice) dictionaries installed. AFAIK you need to configure enchant (rather than LyX) to use it.

The LyX default is hunspell and, as long as you have hunspell and a myspell dictionary matching the language selected in Documents>Settings>Language in one of the many default paths for hunspell, e.g. /usr/share/hunspell /usr/share/myspell, you should be able to use the spellchecking.

Unless there are reasons for not using hunspell, I would suggest going in that direction. Bear in mind that anything greyed out in LyX means that LyX cannot find something in the path where it expects to find it.

Reconfigure is not relevant as that relates to LaTeX packages rather than LyX tools.
Back to top
View user's profile Send private message
fede



Joined: Thu Sep 01, 2005 4:23 am
Posts: 56

PostPosted: Fri Aug 10, 2012 5:29 am    Post subject: Thanks, but it still does not work Reply with quote

Thank you for your explanation, but something is still missing. hunspell, and myspell, and aspell,...) are all installed, and in their proper directory. Again, I can't find any difference between the installation on my System 76 netbook (Ubuntu 12.04, with LXDE), and the one on my Lenovo laptop (same Ubuntu, with KDE), except the desktops, and that is not a possible cause. The problem on the Lenovo came up already when I had it on 10.04, the previous LTS version. I've lived with it all this time, but it's starting to bug me a bit.

By the way, the Lenovo system has another quirk, which is unlikely to be related, but, what do I know? Libre Office Writer can't come up with the editing window for the formula editor. It puts the link (or whatever it is supposed to be) in the document, but prevents any possible editing, meaning no formula can be typed in.

Neither the Ubuntu 12.04 netbook, nor my Mint 13 netbook display either of this nuisances, so I am a bit lost on both...
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8453
Location: Warrington, UK

PostPosted: Fri Aug 10, 2012 9:23 am    Post subject: Reply with quote

Try creating a new user on the system that doesn't work. If it works for them, it is a settings problem, otherwise you are probably missing a package. If it works for the new user, try renaming ~/.lyx for the original user. If that fixes it, it's a matter ofd comparing the contents of ~/.lyx with one of the working systems.

Edit: an afterthought, were any of these systems running LyX 1.x and then upgraded to 2.0?
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
fede



Joined: Thu Sep 01, 2005 4:23 am
Posts: 56

PostPosted: Fri Aug 10, 2012 10:56 pm    Post subject: Lyx spellchecking Reply with quote

Thanks. The new user has no spellchecking either, so, if it's a missing package, I wonder what it could be Shocked (the two netbooks without spellchecking issues started out with 2.0)

However, the computer with this problem did run 1.6 and upgraded to 2.0, even if I don't quite remember how this happened - I am almost thinking I did the upgrade in Ubuntu 10.4 by downloading the 2.0 package from the Lyx site, rather than going through the standard repositories. Could that cause the problem?
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8453
Location: Warrington, UK

PostPosted: Sat Aug 11, 2012 12:21 am    Post subject: Reply with quote

Yes, you could have two versions of some files installed. I'd uninstall both versions, making sure nothing is left in /usr or /usr/local. Then rename the config directories in /etc/and ~ and install afresh from the repos.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
johnhudson
LXF regular


Joined: Wed Aug 03, 2005 2:37 pm
Posts: 870

PostPosted: Sat Aug 11, 2012 9:32 am    Post subject: Reply with quote

I upgraded from 1.6.x to 2.0 without needing to do anything with the LyX configuration but I have a vague memory of having to run
hunspell -D
before spellchecking worked properly. This is the result of running it on my system:

AVAILABLE DICTIONARIES (path is not mandatory for -d option):
/usr/share/myspell/nl_NL
/usr/share/myspell/cs_CZ
/usr/share/myspell/pl_PL
/usr/share/myspell/fr_FR
/usr/share/myspell/en_US
/usr/share/myspell/en_GB
/usr/share/myspell/de_DE
LOADED DICTIONARY:
/usr/share/myspell/en_GB.aff
/usr/share/myspell/en_GB.dic

The important thing is that each dictionary muct have an .aff and a .dic file; so check whether they are pesent.
Back to top
View user's profile Send private message
fede



Joined: Thu Sep 01, 2005 4:23 am
Posts: 56

PostPosted: Wed Aug 15, 2012 4:30 am    Post subject: Reply with quote

nelz wrote:
Yes, you could have two versions of some files installed. I'd uninstall both versions, making sure nothing is left in /usr or /usr/local. Then rename the config directories in /etc/and ~ and install afresh from the repos.

Geez! I feel really bad Sad You are so right: I had both 1.6 and 2.0 and that's what messed it all up! I apologize for taking your time for such a silly mistake... Thanks so much! It's all fine now, after cleaning up all previous installations, and reinstalling the latest version...
Back to top
View user's profile Send private message
lok1950
LXF regular


Joined: Tue May 31, 2005 6:31 am
Posts: 1024
Location: Ottawa

PostPosted: Wed Aug 15, 2012 3:40 pm    Post subject: Reply with quote

Don't feel too bad we all have these Homer moments "doh" besides their are most likely other people who have the same issue.

Enjoy the Choice Smile
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8453
Location: Warrington, UK

PostPosted: Wed Aug 15, 2012 11:27 pm    Post subject: Reply with quote

That's nowhere near bad enough to be a real Homer "doh" moment. I speak from experience Sad
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
Ram
LXF regular


Joined: Thu Apr 07, 2005 10:44 pm
Posts: 1667
Location: Guisborough

PostPosted: Thu Aug 16, 2012 8:35 am    Post subject: Reply with quote

nelz wrote:
That's nowhere near bad enough to be a real Homer "doh" moment. I speak from experience Sad


Which is how you learn... unless your Homer.
_________________

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
Back to top
View user's profile Send private message MSN Messenger
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8453
Location: Warrington, UK

PostPosted: Thu Aug 16, 2012 9:00 am    Post subject: Reply with quote

Experience is what you get when you didn't get what you wanted.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast