Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Mint won't automount USB devices - solution

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Hints and tips
View previous topic :: View next topic  
Author Message
peterm34



Joined: Wed Jan 18, 2012 10:24 am
Posts: 1
Location: Bridgwater

PostPosted: Wed Jan 02, 2013 6:53 pm    Post subject: Mint won't automount USB devices - solution Reply with quote

Having done a fresh install of Mint 14 Mate onto my Aspire 1, I found that my USB memory sticks (and presumably other devices) would not automount when inserted.
It took quite a lot of searching the web and experimentation to find the solution to the problem, so I thought I would share it with other users, to spare your heartache!

It turned out to be two (possibly three) separate issues, either or both of which may apply if you have this problem:

1. The file
    /etc/mtab.fuselock
exists - this prevents devices from being mounted. If you have it, open a terminal sesion and delete it:
Code:
sudo rm /etc/mtab.fuselock

Then reboot.

2. This applies to pre-ext4 filing systems (my solid-state memory is formatted ext2): there is a bug in udisks2 (v2.0.0-1) which means that it fails when trying to mount devices onto filing systems which do not support Access Control Lists (ACL), such as ext2/ext3. This was logged as Ubuntu bug #1048059 and was fixed in December 2012 by a new version of udisks2.

To install the new version, run Synaptic Package Manager from the desktop menu, and search for udisks2.
You need to install version 2.0.0-1ubuntu1. If it is not showing as the latest version, then click the Reload icon. If it is still not showing, then go to Settings -> Repositories -> Other Sources tab, and make sure that both Recommended updates and http://packages.medibuntu.org/ quantal free non-free are selected. Then close that window, and reload again.
Once you have version 2.0.0-1ubuntu1 available, mark udisks2 for upgrade, and click the Apply icon. When the new version has been installed, reboot, and your problems should be over.

3. Before embarking on the above solutions, I noticed in the Package Manager that both udisks and udisks2 were installed. As these were described on one of the web pages as conflicting, I uninstalled udisks. As I did this first, I don't know whether the existence of both packages was contributing to the problem, but this may be another action you need to take.

I hope somebody finds this helpful.

Peter
Back to top
View user's profile Send private message
wyliecoyoteuk
LXF regular


Joined: Sun Apr 10, 2005 11:41 pm
Posts: 3447
Location: Birmingham, UK

PostPosted: Wed Jan 02, 2013 7:46 pm    Post subject: Reply with quote

Welcome to the forum, and congratulations for solving your problem!
_________________
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Hints and tips All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast