Brother printer problem

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Brother printer problem

Postby pk_fox » Mon Jan 07, 2013 1:51 pm

Hi all, my Brother HL-2270DW printer has just stopped printing via my Linux Fedora laptop, the jobs section of the web interface is showing all my jobs as completed but nothing comes out of the printer. I'm running Fedora 17 and haven't used the printer for a couple of months in which time I've had several updates via yum - any ideas ? checked all the usual things paper, cable connected ok etc... The CUPS web interface is not showing any errors either :-( Googled like mad but can't find an answer
User avatar
pk_fox
LXF regular
 
Posts: 298
Joined: Wed Apr 13, 2005 1:38 pm
Location: Surrey, UK

Postby Dutch_Master » Mon Jan 07, 2013 2:03 pm

Brother has excellent Linux support, try re-installing the correct driver:
http://welcome.solutions.brother.com/bs ... index.html
Dutch_Master
LXF regular
 
Posts: 2471
Joined: Tue Mar 27, 2007 1:49 am

Postby pk_fox » Mon Jan 07, 2013 2:17 pm

Dutch_Master wrote:Brother has excellent Linux support, try re-installing the correct driver:
http://welcome.solutions.brother.com/bs ... index.html


Hi I've tried that - lots of nothing happened - as I said the CUPS web interface is reporting all my jobs as completed and there's plenty of paper - I can ping it - stumped here as it was fine last time I used it. One thing I noticed is if I try to print a test page I get a "/usr/lib/cups/filter/bannertops failed" failed message
User avatar
pk_fox
LXF regular
 
Posts: 298
Joined: Wed Apr 13, 2005 1:38 pm
Location: Surrey, UK

Postby Dutch_Master » Mon Jan 07, 2013 2:37 pm

Purge CUPS and re-install that then. Otherwise, try a later version from the CUPS people (not the version in your distro's repo)
Dutch_Master
LXF regular
 
Posts: 2471
Joined: Tue Mar 27, 2007 1:49 am

Postby pk_fox » Mon Jan 07, 2013 3:06 pm

Dutch_Master wrote:Purge CUPS and re-install that then. Otherwise, try a later version from the CUPS people (not the version in your distro's repo)


Hi thanks for your help, how do I purge CUPS ?
User avatar
pk_fox
LXF regular
 
Posts: 298
Joined: Wed Apr 13, 2005 1:38 pm
Location: Surrey, UK

Postby Dutch_Master » Tue Jan 08, 2013 12:58 am

Via yum. Search for the CUPS package then mark it for complete removal.
Dutch_Master
LXF regular
 
Posts: 2471
Joined: Tue Mar 27, 2007 1:49 am

Postby pk_fox » Tue Jan 08, 2013 8:47 am

Dutch_Master wrote:Via yum. Search for the CUPS package then mark it for complete removal.


Hi, I've removed and reinstalled CUPS but things are still broken - it must be a Fedora thing

EDIT

Have found some info on Google it seems quite a few people are having problems similar to mine ( no jokes please ) and seem to think it's a CUPS issue ( which would make sense )
User avatar
pk_fox
LXF regular
 
Posts: 298
Joined: Wed Apr 13, 2005 1:38 pm
Location: Surrey, UK

Postby ferrari » Thu Jan 10, 2013 8:39 am

Is your issue with all print jobs, or just printing pdf-related printing (including browser printing)? There was a similar issue reported in the openSUSE Forums recently as a result of a regression with CUPS and poppler. This will affect other distros too:

https://forums.opensuse.org/english/get ... owser.html

Here's the bug report:

https://bugzilla.novell.com/show_bug.cgi?id=795582
ferrari
LXF regular
 
Posts: 142
Joined: Tue May 03, 2005 11:09 am

Postby pk_fox » Thu Jan 10, 2013 10:21 am

ferrari wrote:Is your issue with all print jobs, or just printing pdf-related printing (including browser printing)? There was a similar issue reported in the openSUSE Forums recently as a result of a regression with CUPS and poppler. This will affect other distros too:

https://forums.opensuse.org/english/get ... owser.html

Here's the bug report:

https://bugzilla.novell.com/show_bug.cgi?id=795582


Hi there, my problem is I can't print anything not even a test page, as I stated earlier the printer was working perfectly until recently, then I updated Fedora a couple of times via yum and now I can't print, I can ping the printer and access its web control panel it just will not print - if I connect it to a Windows PC it works perfectly so I know its not the printer - very strange
User avatar
pk_fox
LXF regular
 
Posts: 298
Joined: Wed Apr 13, 2005 1:38 pm
Location: Surrey, UK

Postby nelz » Thu Jan 10, 2013 12:23 pm

Anything useful in /var/log/cups?
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8577
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby ferrari » Thu Jan 10, 2013 7:20 pm

Are you connected via USB or ethernet? Please post your printer config from /etc/cups/printers.conf, and maybe a good idea to confirm that you still have the Brother driver packages present
Code: Select all
# rpm -qa|grep 2270
ferrari
LXF regular
 
Posts: 142
Joined: Tue May 03, 2005 11:09 am

Postby ferrari » Thu Jan 10, 2013 7:34 pm

If you need to, the verbosity of the CUPS log can be increased by editing the 'LogLevel' directive in /etc/cups/cupsd.conf from 'warn' or 'info' to 'debug' like this
Code: Select all
LogLevel debug


The log of interest is /var/log/cups/error_log
ferrari
LXF regular
 
Posts: 142
Joined: Tue May 03, 2005 11:09 am


Return to Help!

Who is online

Users browsing this forum: No registered users and 1 guest

cron