Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Unable to select boot priority (SOLVED)

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
GregS



Joined: Thu Aug 03, 2006 4:54 am
Posts: 97
Location: Oz

PostPosted: Sun Feb 24, 2013 10:52 am    Post subject: Unable to select boot priority (SOLVED) Reply with quote

SWMBO has just purchases an ASUS Taichi dual-screen (one normal, one touchscreen) NetBook with Windoze 8 pre installed (just the OS, no other software).

I'm trying to run the Ubuntu 12 live DVD from the last LXF; going into BIOS Boot menu has only the Windows boot option that seems to be some form of image as there is an almost Linux-like path statement.

There is a menu item to add another boot source, but no way I can determine of adding the USB DVD I'm trying to use. It certainly does not detect it, nor is there the usual list of drives, NetBoot etc as in previous BIOS (we have an earlier ASUS desktop).

Naturally, "Secure Boot" is enabled; I'm not about to play around without sufficient knowledge but can this be the problem?

Any idea how to articulate a path to a removable drive in this Brave New BIOS?

Right now, all we have is a fairly pricey electronic User manual without many hints on how to actually do anything useful.


Last edited by GregS on Sun Mar 24, 2013 10:13 pm; edited 3 times in total
Back to top
View user's profile Send private message
Fíona



Joined: Sun Mar 09, 2008 5:29 pm
Posts: 56
Location: Netherlands

PostPosted: Sun Feb 24, 2013 11:45 am    Post subject: Reply with quote

I have (fortunately) no experience of win 8 having bought my newest piece of hardware before win 8 was launched.
I suspect, from what I have read that uefi and secure boot, could be your problem. There was a good article in the last lxf about just this and possible work arounds.
One of the suggestions, if I remember rightly, is to turn off secure boot.

Good luck with getting linux onto your new toy.
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8456
Location: Warrington, UK

PostPosted: Sun Feb 24, 2013 12:46 pm    Post subject: Reply with quote

You need to disable Secure Boot. Then hold down a key (Esc on my Asus notebook) to bring up the boot menu within a couple of seconds of power on.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
GregS



Joined: Thu Aug 03, 2006 4:54 am
Posts: 97
Location: Oz

PostPosted: Mon Mar 11, 2013 5:25 am    Post subject: Reply with quote

nelz wrote:
You need to disable Secure Boot. Then hold down a key (Esc on my Asus notebook) to bring up the boot menu within a couple of seconds of power on.


Unfortunately, didn't help (although on the right track - see below).

After an hour on the phone to ASUS Tech support, finally managed to (a) have the tech understand what I wanted to do and then (b) work out the solution (BIOS is AMI 2012):

Disable Secure Boot
Disable Fast Boot
Enable Load CSM

Once that has been done, hitting ESC on boot enables selection of boot medium. Ubuntu 12.10 on LXF 166 now runs perfectly well -.all that remains now is to accomplish an install...!

Stand by for the next exciting episode.
Back to top
View user's profile Send private message
GregS



Joined: Thu Aug 03, 2006 4:54 am
Posts: 97
Location: Oz

PostPosted: Sun Mar 24, 2013 10:39 pm    Post subject: Reply with quote

GregS wrote:
nelz wrote:
You need to disable Secure Boot. Then hold down a key (Esc on my Asus notebook) to bring up the boot menu within a couple of seconds of power on.


Unfortunately, didn't help (although on the right track - see below).

After an hour on the phone to ASUS Tech support, finally managed to (a) have the tech understand what I wanted to do and then (b) work out the solution (BIOS is AMI 2012):

Disable Secure Boot
Disable Fast Boot
Enable Load CSM

Once that has been done, hitting ESC on boot enables selection of boot medium. Ubuntu 12.10 on LXF 166 now runs perfectly well -.all that remains now is to accomplish an install...!

Stand by for the next exciting episode.

OK - Finally solved.
Step one was installation of Ubuntu 12 from the recent cover disk - supposedly, it is UEFI compliant. Installation went OK until GRUB installation, at which time it refused to install anywhere... Rolling Eyes

More internet searching and a download of Fedora 18 - KDE (which is the distro running on all our other systems); and after burning a W8 system image in case it all ended in tears, using Gparted to free up some space, with some trepidation we booted up the live distro.

SWMBO wanted the experience of setting up her own system, so we did a lot of reading of help messages etc. Just as well because it isnt't as straight forward as in the past.

First lesson: permanently disable "secure boot" on any BIOS.

Second lesson: enable 'legacy' boot (AMI call it 'CSM', others may use other terminology) so that booting from other than W8 can occur. Without both these actions, nothing but W8 will boot.

Third lesson: to install on a UEFI system, the installation media must be booted in UEFI mode.

Once we had established these criteria, boot up and selection of install to hard disk went as usual (as an aside, the only significant visible difference with the new installer is that it identified and automatically allocated appropriate sizes to /; /boot; /home and swap -as a separate aside, W8 allocation of partitions and hogging of space by recovery partitions et al is horrendous, nearly all of the 120 Gb HDD is used up prior to installation of any applications...)

Installation, including GRUB, then proceeded without needing any further intervention, other than the usuall setting of passwords, until invited to reboot.

Fedora then faultlessly booted up as normal. The only issue is that GRUB, despite menu entries to the contrary, cannot find a bootable W8 installation...however hitting ESC on boot, to select boot source, provides boot selections for both W8 and F18 in BIOS, both of which work perfectly.

I understand, but have not (yet) gone down that path, that the entire system could be wiped, UEFI included (by booting into BIOS mode during installation) and both W8 (or earlier) and any desired *NIX distro installed in traditional mode; given the grief UEFI incurs, I would recommend that if you have an option to do so.

In the words of a famous philosopher, UEFI appears a 'solution to which there is no problem'!
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8456
Location: Warrington, UK

PostPosted: Sun Mar 24, 2013 10:57 pm    Post subject: Reply with quote

UEFI solves the problem of the ancient creaking BIOS. However, it has two barriers to adoption. One is the need to be in a UEFI booted environment to install a new OS - this is more an awareness problem and will disappear in time along with BIOS. The other problem is really nothing to do with UEFI, it is the dreaded secure boot that has been foisted on us.

Incidentally, my laptop has no BIOS compatibility mode, under any name, but it was still possible to install Linux on it.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
dandnsmith
LXF regular


Joined: Fri Apr 15, 2005 11:01 am
Posts: 308
Location: Berks, UK

PostPosted: Mon Mar 25, 2013 7:14 am    Post subject: Reply with quote

I haven't tried any of this yet (not a sufficiently modern PC), but am slightly confused.
It sounds as if there are 2 conflicting requirements being stated
a) to boot other than Win8 you need to enable legacy boot
b) to install anything you need uefi boot

Can anyone clarify this dichotomy for me?
_________________
Derek
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8456
Location: Warrington, UK

PostPosted: Mon Mar 25, 2013 8:49 am    Post subject: Reply with quote

To install a non-signed OS (basically anything but Win8) you need to disable secure boot.

To install a UEFI bootloader, at least under Linux, you need the install environment to be booted via UEFI. The reason for this is that UEFI exports important information as variables in /sys, information that is needed to install the bootloader.

Legacy boot is not needed, or I would not be sending this as my laptop does not have it.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
GregS



Joined: Thu Aug 03, 2006 4:54 am
Posts: 97
Location: Oz

PostPosted: Wed Mar 27, 2013 12:17 am    Post subject: Reply with quote

nelz wrote:
To install a non-signed OS (basically anything but Win8) you need to disable secure boot.

To install a UEFI bootloader, at least under Linux, you need the install environment to be booted via UEFI. The reason for this is that UEFI exports important information as variables in /sys, information that is needed to install the bootloader.

Legacy boot is not needed, or I would not be sending this as my laptop does not have it.


To clarify, with this specific ASUS product/AMI BIOS, advice from the ASUS techs was that it was necessary to both disable Secure Boot and enable CSM (which they refer to as 'legacy boot mode').

It simply would not boot (nor recognise any external device) with SB alone disabled.

Experience may vary with other configurations... Rolling Eyes
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8456
Location: Warrington, UK

PostPosted: Wed Mar 27, 2013 12:51 am    Post subject: Reply with quote

This is also an Asus laptop and it boots find with CSM disabled. In fact, until I read your previous post, I hadn't realised that CSM was Asusspeak for legacy BIOS emulation.

You do need UEFI-aware media to boot, but you need that to install anyway. I will experiment with CSM as I am currently unable to boot from a USB DVD drive, although I can boot from USB flash drives.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast