Swiss keyboard and GRUB2

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Swiss keyboard and GRUB2

Postby deMike » Tue Feb 26, 2013 5:50 pm

I installed Mint14/Cinnamon in French on my wife's computer. She has a Logitech K200 Swiss USB keyboard. There are no problems once Linux is running, however when the GRUB menu is displayed the ENTER and UP/DOWN arrows do not work. I cannot select RECOVERY MODE, MEMORY TEST or OTHER OS. I have to wait for the count-down to go to zero which will then start Mint. Similarly, if I boot from an LXF cover disk I can see the menu but can go no further. If I change the keyboard for a US PS/2 keyboard all the keys function and once in Mint my American keyboard is recognised as Swiss, i.e. I type QWERTY and get QWERTZ, so the problem appears to be in GRUB and not Mint. Is there a solution other than having a second keyboard to hand?

Thanks,
Mike
deMike
 
Posts: 2
Joined: Tue Feb 26, 2013 11:03 am

Postby nelz » Tue Feb 26, 2013 6:52 pm

The problem is in your BIOS settings. You need to enable the option called "USB legacy mode" or something similar for USB keyboards to work with the BIOS. GRUB uses the BIOS code for this, whereas once the kernel is loaded, its own USB and keyboard handlers are used.

The other keyboard works because it is PS2, this has nothing to do with the language.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8523
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Thanks!

Postby deMike » Tue Feb 26, 2013 7:55 pm

Thanks, nelz, for your rapid and very helpful reply. I don't have any USB American keyboards, only PS/2, and was not really able to compare like with like.

Following your suggestion I looked into the BIOS and found:
USB Controller - Enabled
USB 2.0 Controller - Enabled
USB Keyboard Support - Disabled
USB Mouse Support - Disabled
USB Legacy Storage detect - Enabled
I switched the two disabled options to enabled and now everything works OK. Well, almost. In the BIOS the Y key (for Yes) is still in the US position, i.e. the Swiss Z key, but that is no problem.

Many thanks,
Mike
deMike
 
Posts: 2
Joined: Tue Feb 26, 2013 11:03 am


Return to Help!

Who is online

Users browsing this forum: No registered users and 2 guests