Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Problems accessing ( some ) dvds

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
i.couchman
LXF regular


Joined: Thu Jul 13, 2006 11:43 am
Posts: 225

PostPosted: Sun Mar 31, 2013 5:18 pm    Post subject: Problems accessing ( some ) dvds Reply with quote

I'm having trouble accessing some dvds. It's all down to permissions, but I can't work out how to get over it.

I'm running Debian 6

My fstab entry is:
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto,umask=000,uid=ian,gid=ian,rw,exec 0 0

The disc mounts OK, but ls /media/cdrom0 -l as root gives me :
dr--r--r-- 2 ian ian 664 Mar 3 2006 VIDEO_TS

Doing the same as me gives:

ls: cannot access /media/cdrom0/VIDEO_TS: Permission denied
total 0
?????????? ? ? ? ? ? VIDEO_TS

The only way I can get at the videos is by copying to the hard drive & changing owner. I understand that the problem is caused by the recorder which produced the disc putting iffy permissions on it, but how do I get at the files to view them?
Ian
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8453
Location: Warrington, UK

PostPosted: Sun Mar 31, 2013 6:41 pm    Post subject: Reply with quote

umask is not a valid option for iso9660 filesystems, you should be using mode instead. You can't read the directories because the execute bit is not set for them. Either add mode=555 to the fstab line or remove it altogether and let your desktop's automounter take care of it all.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
i.couchman
LXF regular


Joined: Thu Jul 13, 2006 11:43 am
Posts: 225

PostPosted: Sun Mar 31, 2013 6:57 pm    Post subject: Reply with quote

Quote:
add mode=555 to the fstab line

Tried that. No change.

commented out the whole line.
Auto mounter mounts under /media/DVD_VIDEO_RECORDER

with ls -l as me giving:
total 0

& ls -l as root giving:
dr-------- 3 ian ian 88 Mar 3 2006 DVD_VIDEO_RECORDER
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast