Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

New NAS - Cant mount/see HDD drives [SOLVED]
Goto page 1, 2, 3, 4, 5  Next
 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
GeordieJedi
LXF regular


Joined: Thu Jun 14, 2007 11:36 pm
Posts: 335
Location: North East England

PostPosted: Wed May 15, 2013 12:05 am    Post subject: New NAS - Cant mount/see HDD drives [SOLVED] Reply with quote

Hi all.

OK, I've finally taken the plunge and gotten a fantastic nice new shiny NAS
(A Synolgy DS413J)

However I'm struggling to get my NAS HDDs mounted and visable on my PC/network.

I've ran through the setup (using Synolgy Disk Station Manager = DSM).
I can connect to the NAS via a web broswer fine.

My main question is this -

1. How do I now get my NAS and it's HDD's to appear/mount/be usable on my network
so that either PC can connect to it and share/swap data and files ?


Do I need to create some mount points in the FSTAB ?
I gave it a try and got the following error messages

command =
Code:
root@[PC name]:~/Documents# mount 192.168.x.xx:xxxx/volume1/video /media


error message =
Code:
mount: wrong fs type, bad option, bad superblock on 192.168.x.xx:xxxx/volume1/video,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so


I beleive it's because I left a colon from the end of the IP address ?


I then tried again with the colon and got the following error =
Code:
bash: 192.168.x.xx:xxxx:/volume1/video: No such file or directory



Here is one of the lines from my FSTAB relating to my NAS box.
Code:
192.168.x.xx:xxxx/volume1/video      ext4   defaults   0   0



Useful info

Ubuntu 12.04
DE = KDE


Virgin media cable modem/router (downstairs)
Cat cable run upstairs to switch (upstairs in office)
PCs and NAS connected to switch (upstairs in office)


Synology DS413J NAS =
2x 3TB HDD's in Synolgys hybrid RAID array (Kinda RAID 1) making a total of
2.68 TB usable space


Any help or advice would be grateful appreciated !
Thanks.


Last edited by GeordieJedi on Mon Jan 13, 2014 8:29 pm; edited 2 times in total
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8457
Location: Warrington, UK

PostPosted: Wed May 15, 2013 12:16 am    Post subject: Reply with quote

It would be easier if you gave the actual address you are using (it is a private address to your network so there's no risk in exposing it) In particular, is the xxxx a port number? It looks like it but it is not usual to use port numbers with NFS. For example, here is an NFS line from my fstab - using a hostname rather than an IP address, but that shouldn't make a difference.

Code:
lunkwill:/mnt/portage  /mnt/portage  nfs  rsize=8192,wsize=8192,soft  0 0


The simple command line equivalent, without the options, is

Code:
mount lunkwill:/mnt/portage -t nfs /mnt/portage

_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
GeordieJedi
LXF regular


Joined: Thu Jun 14, 2007 11:36 pm
Posts: 335
Location: North East England

PostPosted: Wed May 15, 2013 10:38 pm    Post subject: Reply with quote

Hi there nelz.

I've changed the hostname of my NAS now (as it's a lot easier to type).

I've tried a few quick experiments with the FSTAB and I did manage to get some mount points created by adding
this line to the FSTAB file =

Code:
Hoth:/volume1/photo /mnt/photo_share/photo nfs nouser,atime,auto,rw,dev,exec,suid 0 0


So the mount points showed up on the mnt dir, but they were owned by root
I then tried a chown to my username but then bash said that the dirs did not exist !
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8457
Location: Warrington, UK

PostPosted: Wed May 15, 2013 11:20 pm    Post subject: Reply with quote

You need to set ownerships after the filesystem is mounted, changing the owner of the mount point does nothing.

Can you SSH into the NAS? What does "exportfs" say.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
GeordieJedi
LXF regular


Joined: Thu Jun 14, 2007 11:36 pm
Posts: 335
Location: North East England

PostPosted: Thu May 16, 2013 10:28 pm    Post subject: Reply with quote

Ok.

command =
Code:
exportfs


result =
Code:
The program 'exportfs' is currently not installed.  You can install it by typing:
sudo apt-get install nfs-kernel-server



I've read that I "should ?" get a programme called nfs-custom installed too.
Is this useful/necessary to get my NAS working properly ?

Also, i've not tried to SSH into it yet (not entirely sure how to).


Additionally -

When using dolphin to look at my file structure, the NAS shares (kind of show up).
In the sense that they appear in the left pane. But When I click on them I get the error message =

"An error occurred while accessing 'volume1/music on Hoth', the system responded:
mount:only root can mount Hoth:/volume1/music on mnt/music_share/music"

However If I navigate to the root dir then goto the mnt dir
I can actually click and access the NAS share dirs.

(But they are still obviously owned by root and I cant do much
with them).


It seems very strange
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8457
Location: Warrington, UK

PostPosted: Thu May 16, 2013 10:37 pm    Post subject: Reply with quote

If you haven't tried SSH, how did you run exportfs? Or did you run it on the client? I meant to run it on the NAS, it shows how its NFS shares are set up.

Can you mount the shares as root? Only root can mount devices not in /etc/fstab, so you need to add them there and put "users,noauto" in the list of options to allow any user to mount a share on demand. Or leave those options out and let the shares mount when you boot - depending on whether the NAS is always available.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
GeordieJedi
LXF regular


Joined: Thu Jun 14, 2007 11:36 pm
Posts: 335
Location: North East England

PostPosted: Sun May 19, 2013 9:47 pm    Post subject: Reply with quote

I ran exportfs as a bash command on my PC.

I "looks like" I can mount the drives as root.
If I navigate to the mnt dir, I then see the following dirs -

music_share
photo_share
video_share

(these are the names I've given to the three corresponding dirs on the NAS.
I believe you have to give them a different name than dirs on the NAS box itslef ?).

I currently have the following line in my FSTAB =
Code:
Hoth:/volume1/video /mnt/video_share/video nfs nouser,atime,auto,rw,dev,exec,suid 0 0


I intend to have the NAS on permanently (once I get this sorted).
So should I change/add the options "users,noauto" in the FSTAB ?


Thanks.
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8457
Location: Warrington, UK

PostPosted: Sun May 19, 2013 9:56 pm    Post subject: Reply with quote

Running exportfs on the PC tells you nothing of relevance.

If you can mount them as root from fstab, then all is fine. Once mounted they worls like normal Linux filesystems so you set permissions with chown and chmod in the usual way, after mounting them.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
GeordieJedi
LXF regular


Joined: Thu Jun 14, 2007 11:36 pm
Posts: 335
Location: North East England

PostPosted: Sun May 19, 2013 10:41 pm    Post subject: Reply with quote

When I use dolphin to navigate the fs,
The NAS shares show up on the left hand pane
(looks like a networked drive icon).
But When I click on them I get the error -

"An error occurred while accessing 'volume1/music on Hoth', the system responded:
mount:only root can mount Hoth:/volume1/music on mnt/music_share/music"

However If I navigate there by clicking on the mnt dir it looks like this -

root>mnt (it shows the following 3 dirs)
music_share
photo_share
video_share

Then If I click onto music share =
root>mnt>music_share

Once I click onto music_share it looks like this
root>mnt>music (as it would appear on the NAS)

If I click on the music dir, things change to this =
/volume1/music on hoth

I tried an experiment, and created a dir called "test" Dolphin let me create the dir.
However If I go into the NAS via the web browser, my test folder doesn't appear in the music dir.
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8457
Location: Warrington, UK

PostPosted: Sun May 19, 2013 10:56 pm    Post subject: Reply with quote

It sounds like the share is not mounted, the directory is still there but the file you create is in the root filesystem, not on the share. What is the output (on the PC) from this?

Code:
mount | grep nfs

_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
GeordieJedi
LXF regular


Joined: Thu Jun 14, 2007 11:36 pm
Posts: 335
Location: North East England

PostPosted: Sun May 19, 2013 11:24 pm    Post subject: Reply with quote

The result is nothing.

The command executes and there is no response and then it returns to the next line.
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8457
Location: Warrington, UK

PostPosted: Mon May 20, 2013 12:38 am    Post subject: Reply with quote

That means you have no nfs shares mounted.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
GeordieJedi
LXF regular


Joined: Thu Jun 14, 2007 11:36 pm
Posts: 335
Location: North East England

PostPosted: Mon May 20, 2013 10:55 pm    Post subject: Reply with quote

How do I mount my NAS shared folders/HDD's ?

What am I missing to let me do this ?
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8457
Location: Warrington, UK

PostPosted: Mon May 20, 2013 10:57 pm    Post subject: Reply with quote

Suitable lines in /etc/fstab, what to you have in there for the shares?
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
GeordieJedi
LXF regular


Joined: Thu Jun 14, 2007 11:36 pm
Posts: 335
Location: North East England

PostPosted: Mon May 20, 2013 11:01 pm    Post subject: Reply with quote

Here's the relevant portion of my fstab =

Code:
Hoth:/volume1/video /mnt/video_share/video nfs nouser,atime,auto,rw,dev,exec,suid 0 0
#
Hoth:/volume1/photo /mnt/photo_share/photo nfs nouser,atime,auto,rw,dev,exec,suid 0 0
#
Hoth:/volume1/music /mnt/music_share/music nfs nouser,atime,auto,rw,dev,exec,suid 0 0



Additionally, do I need the smbfs and nfs-common packages installed ?
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Goto page 1, 2, 3, 4, 5  Next
Page 1 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast