Linux Mint 14 missing mouse clicks?

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Linux Mint 14 missing mouse clicks?

Postby Nox » Wed Jul 03, 2013 11:01 am

Hello all,
Installed Linux Mint 14 Cinnamon-64 bit (lxf167) yesterday and I'm starting to notice some missed clicks. When switching between windows, its very hard to get the focus shifted from the inactive window. For example if I highlight and ctrl-c some code snippet in Firefox then alt-tab to terminal, it frequently will be un-clickable when it comes to the front, and I'll have to tab away and back once or twice to be able to click anything. (Such as finally being able to right click and tell it to paste.)

It's a Saitek Cyborg rat3 mouse (usb) which, frankly, I'd hate to give up. Works fine on WinXP and the other Bootables from lxf.

Any hunches?
Nox
 
Posts: 14
Joined: Wed Jul 03, 2013 5:29 am
Location: Ohio, U.S.A.

Postby Nox » Mon Jul 22, 2013 12:49 am

Noticed my post had plenty of views but no replies, since I'm new on these forums I wonder if I asked for help properly? (or if its just a real stumper)

It's still frustratingly difficult to tab between things, or even just open the browser (for example,) and be able to click. I can click on the Firefox launcher in the task bar but once its open I have to alt+tab to be able to click on it. This is the simplest and most predictable click it will miss/ignore.

Are there any log files I can check or post that would be helpful?

I have Google-ed away for Linux mint and mouse issues, but while I do find others having mouse issues nothing sounds similar. (honestly I could just be missing some obvious connection between my problem and someone else's, but being fairly new to Linux how would I know?)

In short, I'm just re-stating my question and checking to make sure I'm doing my due diligence on this end before I have to jump to a different Linux flavor just to fix this.
Nox
 
Posts: 14
Joined: Wed Jul 03, 2013 5:29 am
Location: Ohio, U.S.A.

Postby Nox » Mon Jul 22, 2013 1:19 am

Update!

Tried something I should have thought of long ago... swapped mice. A generic mouse works 100%.

Which seems to indicate that my mouse and mint don't get along. (insert devastated smiley here)

Re-googled and after a few dozen re-wordings and a hint from a friend that Mint is close enough to Ubuntu, I've been working through this:

http://askubuntu.com/questions/92546/pr ... ming-mouse

Editing Xorg,conf is deeper into to the Linux pool than I usually go, but I love my mouse...
Last edited by Nox on Mon Jul 22, 2013 2:53 am, edited 1 time in total.
Nox
 
Posts: 14
Joined: Wed Jul 03, 2013 5:29 am
Location: Ohio, U.S.A.

Re: Linux Mint 14 missing mouse clicks?

Postby Alex01UK » Mon Jul 22, 2013 2:29 am

[quote="Nox"]Hello all,
Installed Linux Mint 14 Cinnamon-64 bit (lxf167) yesterday and I'm starting to notice some missed clicks.

good choice; isn't Linux Mint 15 out know? 64 bit Cinnamon is the won to go for. I run Ubuntu, mainly cos the servers are shit hot fast 16.6Mbps 24/7 when doing updates. Gnome 3.6 desquetop Realtime Kernel for zero latency; instant sound response...... and all the video / photo / music ****..
Chrome OS: Samsung ARM Series 3 Chromebook, 32bit ARM Ubuntu 12.o4 HFCE.
64bit Windows 7 Home Premium, 64bit Ubuntu Studio 14.o4, 32bit Mint 17 MATE.

''I am what I am, because we are what we are.''
User avatar
Alex01UK
LXF regular
 
Posts: 242
Joined: Thu Jun 14, 2012 4:31 pm
Location: Scarborough, North Yorkshire, United Kingdom

Postby Nox » Mon Jul 22, 2013 2:48 am

After attempting the previously linked fix to no effect, I have a "throwing-darts-in-the-dark" hunch. I think my Xorg.conf has multiple entries regarding mouse hardware.

Heres the entry that makes me wonder:

Code: Select all
Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection


Does this need deletion/editing? Xinput tells me my mouse id is 8, which doesn't match this, but the link I've been following mentions nothing of altering other sections than the one it says to add.

Also of note I had to switch mice to even be able to open gedit while Firefox was up, or it would toss an error. I'll caveman copy/paste (pencil&paper) that error here tomorrow.
Nox
 
Posts: 14
Joined: Wed Jul 03, 2013 5:29 am
Location: Ohio, U.S.A.

Postby guy » Mon Jul 22, 2013 11:47 am

Hi,

This all seems so weird - the OS works fine with other mice, the mouse works fine with other OS.

Does your mouse have some magic feature not available to mere mortal mice? Possibly with a Windows (TM) driver CD alongside?
Cheers,
Guy
The eternal help vampire
User avatar
guy
LXF regular
 
Posts: 1078
Joined: Thu Apr 07, 2005 12:07 pm
Location: Worcestershire

Postby PCNetSpec » Tue Jul 23, 2013 1:09 am

WARNING: You are logged into reality as 'root'... logging in as 'insane' is the only safe option.
Linux in the UK
The Linux Community Forum
User avatar
PCNetSpec
LXF regular
 
Posts: 631
Joined: Sun Feb 21, 2010 3:50 pm
Location: Cornwall UK

Postby Nox » Tue Jul 23, 2013 5:52 am

guy: nope no driver cd, however it says right on the box designed for win xp 64... honestly not that I know the specific difference is or if its just a straw man issue to make win users feel warm and fuzzy

PCNetSpec: I'll try that one soon have to wait on printouts since I need the rat3 plugged in to see the correct xinput stuff, and that makes tabbing between Firefox and the terminal a very large pain!


As promised from yesterday the error it throws (while Firefox is open) when trying to do this:

Code: Select all
gksu gedit /etc/X11/xorg.conf


Is titled:
could not grab your mouse

It then goes on saying its either a malicious network member spying on me or that some app just won't give up the window focus. Given it doesn't happen when I change mice, it's either the most fortuitously timed repeat attack ever... or just as it seems, the mouse.
Nox
 
Posts: 14
Joined: Wed Jul 03, 2013 5:29 am
Location: Ohio, U.S.A.


Return to Help!

Who is online

Users browsing this forum: No registered users and 0 guests