Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Printer probs....
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Wed Mar 12, 2014 3:27 pm    Post subject: Printer probs.... Reply with quote

I am trying to add my Samsung ML-1670 laser to my system and have installed the relevant Samsung drivers. In on order to effect the addition I have had to specify the ppd file and this I have done. I got an error message from the printer management screen to the effect that I must first add
Code:
rastertosplc
to [/code] /usr/lib/cups/filter/[code] and that is what I am trying to do.
The file resides in [code]/home/david/uld/.386/rastertosplc[/code].
Using Gnome Commander with both directories open to me I can copy the file but am unable to paste it into /usr, even as root.
Can anyone please advise me - I am willing to use the command line but I need a steer, please.

Best regards
David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
Dutch_Master
LXF regular


Joined: Tue Mar 27, 2007 2:49 am
Posts: 2430

PostPosted: Wed Mar 12, 2014 3:54 pm    Post subject: Reply with quote

The general command structure is:
Code:
cp [options] <source> <destination>

So in your case:
Code:
cp /home/david/uld/.386/rastertosplc /usr/lib/cups/filter/


If your system uses sudo, precede the previous command accordingly Smile

Bookmark this: http://ss64.com/bash/ Exclamation
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Wed Mar 12, 2014 6:05 pm    Post subject: Printer probs.... Reply with quote

Thanx DM for your prompt reply.

Code:
cp: cannot stat '/home/david/uld/.386/rasterostplc': No such file or directory
is the reply.

I have wrestled with this all afternoon.

Can you see if I have made any mistake, please?

Best regards

David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
Dutch_Master
LXF regular


Joined: Tue Mar 27, 2007 2:49 am
Posts: 2430

PostPosted: Wed Mar 12, 2014 7:36 pm    Post subject: Reply with quote

This command
Code:
updatedb && locate rasterostplc | grep /home/
will give you the exact location of the rasterostplc file in the /home directory. Note very carefully where it is, then navigate to it via the cd command:
Code:
cd /home/<path/to/file>
The ls command shows you the contents of that directory. Check the file is there. Then, re-issue the cp command I gave earlier.

You can use the ls command to check contents of another directory, if you provide a path to it:
Code:
ls /usr/lib/cups/filter/
This should now show the rasterostplc file inside it.
Back to top
View user's profile Send private message
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8450
Location: Warrington, UK

PostPosted: Wed Mar 12, 2014 7:45 pm    Post subject: Reply with quote

You have spelled the name differently, rastertosplc vs rasterostplc. Use tab completion instead of typing the paths in full, that way you know it is correct.

Or you can use find
Code:
find ~/uld -name 'raster*'

to find the file.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Thu Mar 13, 2014 3:27 pm    Post subject: Printer probs.... Reply with quote

DM and NELZ, wot a pair of stars you are!

I am pretty confident I can do the rest now. I will let you know how I get on.

Best

David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Thu Mar 13, 2014 6:32 pm    Post subject: Printer probs.... Reply with quote

DM and Nelz, Thank you so much for your expert guidance.

I have copied the file to the right place and verified it.

I still do not have a working printer, but I think I know why.

I now know how to install it correctly and I shall uninstall (having taken good copies of the relevant locations and file names and addresses) so I can easily specify them again.

Altho´ I did go to Specsavers I am now 72 and the 7 strokes and one episode of Thrombosis have left their mark...

Many thanx

David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Sat Mar 15, 2014 12:10 pm    Post subject: Printer probs.... Reply with quote

Hi Guys!
Sadly there is still work to do.
I managed to copy the file rastertosplc to /usr/lib/cups/filter and verified that it was there as root owner.
The problem is that I could not print any thing. Digging around I found under print queue attributes the statement that ¨filter failed¨.
In case the installation had become corrupted I moved all my various downloads to trash and went to the Samsung site for a fresh (untainted) download. This is a new type, only issued yesterday But I managed to install it. I still get the same filter failed message and I have run out of grunt.
Any ideas anyone, please?
Best regards
David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
Dutch_Master
LXF regular


Joined: Tue Mar 27, 2007 2:49 am
Posts: 2430

PostPosted: Sat Mar 15, 2014 2:44 pm    Post subject: Reply with quote

Are the permissions correct? Set to
Code:
chmod 644 /usr/lib/cups/filter/rastertosplc


Are you installing the drivers according to the Samsung instructions? Reboot the PC to make sure all relevant services (Cups, lpr) are started correctly.
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Sun Mar 16, 2014 2:53 pm    Post subject: Printer probs.... Reply with quote

DM thank you for your continuing support.
Overnight I had a Eureka moment, reasoning that filter was part of the CUPS kit I might as well re-install it. So I did, but it still fails. I have just applied your chmod change and it is still the same.
IT seems to me that there are 2 paths: I should reassess my installation procedure, or I could reinstall Mint 15, which worked perfectly after a bit of tinkering.
It has now been 2 weeks and I am exhausted.....
Best regards
David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
wyliecoyoteuk
LXF regular


Joined: Sun Apr 10, 2005 11:41 pm
Posts: 3440
Location: Birmingham, UK

PostPosted: Sun Mar 16, 2014 10:14 pm    Post subject: Reply with quote

How are you installing?
I have a Samsung printer, and the only filters I can find are rastertosamsungpl and rastertosamsungplc.
try entering http://localhost:631 in a web browser, and adding the printer that way.
On my ubuntu syatem the driver is already available.
_________________
The sig between the asterisks is so cool that only REALLY COOL people can even see it!

*************** ************
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Mon Mar 17, 2014 9:56 am    Post subject: Printer probs.... Reply with quote

Thanks Wylie, I have installing using localhost:631 and it still does not print. The message I get is ¨filter failed¨
I have looked at
Code:
/usr/lib/cups/filter/rastertosplc
and it is set as root.

I have just noticed DM´s instructions to chmod to 644 so I will try that and see if it works.

Best regards

David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Mon Mar 17, 2014 10:19 am    Post subject: Printer probs.... Reply with quote

Further to my last I have chmod 644 to rastertosplc and I get the message from job-printer-state-reasons-
Code:
[u´cups-insecure-filter-warning´]

I shall change back to root and do some more head-scratching.

Incidentally, I have also tried
Code:
/home/david/downloads/uld/ and installed [.sh] and then [install.sh] and the same result occurs.

I can´t think of anything else I can do.

I think I will go for a walk to clear me bonce...

Best

David

_________________
Semper in Excretam
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Mon Mar 17, 2014 2:31 pm    Post subject: Printer probs.... Reply with quote

I carried a clearout in which I deleted the printer and deleted rastertospic and installed the printer from the archive as:
Code:
cd /home/david/Downloads/uld

then
Code:
sudo  /home/david/Downloads/uld/.install.sh

At the printers setup box in sys settings the dialog allowed me to specify the Samsung printer after I pointed it to the location of the .ppd file and informed me that file rastertosplc need to be installed in :
Code:
/usr/lib/cups/filter
and I duly copied the file from:
Code:
~/uld/i386/rastertosplc
to
Code:
~/cups//filter/

I then checked the file had root owner permission
I still get the same ¨filter failed¨ message and I wonder if the raster file has been properly installed in the /filter dir.
Can anyone shine a light into my gloom, please?
Best
David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Tue Mar 18, 2014 3:15 pm    Post subject: Printer probs.... Reply with quote

I may be on to something here.

http://localhost:631/admn/printers[code] gets me the CUPS website.
pointing to my printer and then I see, on the top of the page [code]Idle, accepting jobs,stopped, server default[/code]

I can´t help thinking that I must be able to register my printer to Cups, and this might be the reason behind the ¨filter failure¨ message.

Any thoughts?

Best

David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast