Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Printer probs....
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
tfranc



Joined: Mon Mar 17, 2014 6:34 pm
Posts: 3
Location: Sweden

PostPosted: Tue Mar 18, 2014 6:27 pm    Post subject: Re: Printer probs.... Reply with quote

DavidMcCrossan wrote:
I may be on to something here.

http://localhost:631/admn/printers[code] gets me the CUPS website.
pointing to my printer and then I see, on the top of the page [code]Idle, accepting jobs,stopped, server default[/code]

I can´t help thinking that I must be able to register my printer to Cups, and this might be the reason behind the ¨filter failure¨ message.

Any thoughts?

Best

David
Quote:



Hi David
I hade the same problem after the ML1670 printer drive installation.
The filter file rastertosplc was missing and it seams to be obsolete.
My solution
In the directory /usr/lib/cups/filter/ I found a link called, nearly the same, rastertospl linked to /opt/smfp-common/printer/bin/rastertospl
I did a test by creating a new link with the name rastertosplc to the same link by following command:
ln -s /opt/smfp-common/printer/bin/rastertospl rastertosplc
and then the printer works with no errors.
I use CentOS 6.5

I hope this helps
tfranc
Back to top
View user's profile Send private message
tfranc



Joined: Mon Mar 17, 2014 6:34 pm
Posts: 3
Location: Sweden

PostPosted: Tue Mar 18, 2014 7:15 pm    Post subject: printer problems Reply with quote

Quote:
Hi David
I had the same problem after the ML1670 printer drive installation.
The filter file rastertosplc was missing and it seams to be obsolete.
My solution
In the directory /usr/lib/cups/filter/ I found a link called, nearly the same, rastertospl linked to /opt/smfp-common/printer/bin/rastertospl
I did a test by creating a new link with the name rastertosplc to the same link by following command

Code:
ln -s /opt/smfp-common/printer/bin/rastertospl rastertosplc
Quote:
and then the printer works with no errors.
I'm using CentOS 6.5

I hope this helps
tfranc
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Wed Mar 19, 2014 9:21 am    Post subject: Printer probs.... Reply with quote

Thanks tfranc.
I deleted rastertosplc from
Code:
/usr/lib/cups/filter/
and copied
Code:
/home/david/Downloads/uld/arm/rastertopl
instead.

I still do not get a print, but the message is
Code:
Idle /usr/cups/filter/rastertoptosplc
no such file exists.

Clearly I have to edit a file some where to tell it to use rastertospl instead.

I have no idea where to go.

Can anyone help please?

Best

David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Wed Mar 19, 2014 10:20 am    Post subject: Printer probs.... Reply with quote

Further info....

I went on a wild goose chase around /usr/cups/filters/, replacing the raster file to the tospl and then to the cupsd. file and even altered the ppd file, but none of this worked so I came back to the beginning.

The curious thing is that under /Downloads/uld/arm I found the tospl file and in /uld/.386/ is the tosplc file.

I am back to the ¨filter failed¨ warning, as before.

There´s a clue here somewhere.

Best regards

David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Wed Mar 19, 2014 3:24 pm    Post subject: Printer probs [SOLVED] Reply with quote

I got out of Mint 16 32 and am making progress with my old Mint15 64.

Many thanks to all for your kind support.

Best regards

David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
tfranc



Joined: Mon Mar 17, 2014 6:34 pm
Posts: 3
Location: Sweden

PostPosted: Wed Mar 19, 2014 7:44 pm    Post subject: printer problems Reply with quote

Hi David
Maybe you misunderstood me? In the directory /usr/lib/cups/filter/ you must have a file (or a link) with the name rastertosplc.
I created a link with the name rastertosplc pointing to another file with name rastertospl, described in the previous post.
An other way is to copy the file rastertospl to the name rastertosplc as:
Code:
cp rastertospl rastertosplc

in the directory /usr/lib/cups/filter/

regards tfranc
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Fri Mar 21, 2014 2:45 pm    Post subject: printer probs Reply with quote

Thanks tfranc, but I got too tired and unistalled Mint16-32 and reverted to Mint15-16, whic was working well for me.

I am still having problems and have again asked for help with nVidia drivers as you will see from my latest post.

Best regards

David
_________________
Semper in Excretam
Back to top
View user's profile Send private message
DavidMcCrossan
LXF regular


Joined: Fri Aug 19, 2005 10:46 am
Posts: 326

PostPosted: Sun Mar 30, 2014 6:07 pm    Post subject: <SOLVED> Printer probs Reply with quote

With help from tfranc I finally worked out was happening.

Go to the Samsung website and download uld and install according to the instructions given in the ULD Usersguide and you may fail.

I have found that you must install
Code:
rastertosplc
for a 64-bit distro into
Code:
/usr/lib/cups/filter/
or you will get a message saying "filter failure".

Do this first and all will be well.

The web site tells you to download
Code:
/uld/ into (eg) /home/david/ and then unpack it, go to the command line and navigate to the folder and (as root) /install.sh and you will be invited to print a test page.

Simples.....

Only took me 3 weeks. And then only when I found the file in my backup 2 USB, 'cos it was not in the uld folder....

Best

David, and thanx Ted

_________________
Semper in Excretam
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast