Superblock corrupt?

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Superblock corrupt?

Postby gaz_dc » Wed May 04, 2005 10:06 pm

Having finally managed to install Gentoo (stage 3), I re-booted my PC. Gentoo seems to load fine until I hit some errors during the boot process. The first hint of trouble is a message saying the following;

Starting devfsd...
/sbin/rc: line 271: /sbin/devfsd: No such file or directory

It then carries on, activating the swap and mounting the root filesystem. However, when it tries to check the filesystem I get the following;

Checking root filesystem...
fsck.ext3: No such file or directory while trying to open /dev/hdb3
/dev/hdb3:
The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or something else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>
Filesystem couldn't be fixed : (

It then gives an option of logging in as root or a normal start, which just reboots the system.

Any ideas? What have I done wrong? I seem to have got myself in a bit of a hole!

Here is my fstab file, if its any help;

/dev/hdb1 /boot ext2 defaults,noatime 1 2
/dev/hdb2 none swap sw 0 0
/dev/hdb3 / ext3 noatime 0 1

none /proc proc defaults 0 0
none /dev/shm tmpfs nodev,nosuid,noexec 0 0

Thanks for your time
gaz_dc
 
Posts: 5
Joined: Wed May 04, 2005 9:43 pm

RE: Superblock corrupt?

Postby fairless » Sun May 08, 2005 10:43 pm

I may be leading you down the wrong track, but have a look at the website of your harddrive manufacturer and see if they have any test utilities. It could be a hard ware issue that can be resolved through running a utilities boot disk.

Neil
User avatar
fairless
 
Posts: 27
Joined: Sat May 07, 2005 12:31 am

RE: Superblock corrupt?

Postby gaz_dc » Mon May 09, 2005 4:46 pm

Good idea, but I don't think that is the problem. I can install and boot other distros on the same hd without any problems (Mepis, Slackware, Debian etc).

Thanks for the thought though.

Gaz
gaz_dc
 
Posts: 5
Joined: Wed May 04, 2005 9:43 pm

Postby mugstar » Tue May 10, 2005 11:58 am

Your fstab shows ext3, but fsck seems to be expecting ext2. I would try editing fstab...
Not too sure to be honest, I've fscked up superblocks before and had to start over :cry:
mugstar
LXF regular
 
Posts: 184
Joined: Mon Apr 11, 2005 12:43 am
Location: Scotland

Postby nelz » Tue May 10, 2005 12:10 pm

Did you compile your kernel manually or using genkernel?

Is this a 2005.0 install? If so, you shouldn't really be using devfs. Set all devfs settings in /etc/conf.d/rc to no and recompile the kernel without devfs. It is supposed to be OK to run a devfs-enabled kernel under udev, I've done it myself, as long as you haven't set devfs to mount at boot, but some people seem to have problems with this, that are solved by removing devfs entirely.
User avatar
nelz
Site admin
 
Posts: 8493
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby gaz_dc » Tue May 10, 2005 5:03 pm

OK, will give that a try and post back with results...

FYI, I comiled the kernel manually following the hand book as closely as possible.
gaz_dc
 
Posts: 5
Joined: Wed May 04, 2005 9:43 pm


Return to Help!

Who is online

Users browsing this forum: No registered users and 1 guest