Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

External USB HDD
Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
youlikeicecream
LXF regular


Joined: Fri Jun 03, 2005 12:40 pm
Posts: 721
Location: Oxford

PostPosted: Sat Jun 04, 2005 10:42 am    Post subject: RE: External USB HDD Reply with quote

drwxr-xr-x 9 root root 32768 2005-06-04 10:39 LACIE

is my Dir listing
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
youlikeicecream
LXF regular


Joined: Fri Jun 03, 2005 12:40 pm
Posts: 721
Location: Oxford

PostPosted: Sat Jun 04, 2005 10:56 am    Post subject: RE: External USB HDD Reply with quote

after clicking the auto icon on the desktop which mounts /dev/sdb1 to /media/sdb1

i used mount to move the mounted directory :

root@Kubuntu:/mnt/LACIE # mount --move /media/sdb1 /mnt/LACIE
root@Kubuntu:/mnt/LACIE # cd ..
root@Kubuntu:/mnt # ls -la
total 76
drwxr-xr-x 6 root root 4096 2005-06-02 00:25 .
drwxr-xr-x 22 root root 4096 2005-06-01 18:38 ..
drwx------ 9 mike mike 32768 2005-06-04 10:51 LACIE
drwxr-xr-x 4 root root 16384 1970-01-01 01:00 LinMusic
drwxr-xr-x 5 root root 16384 1970-01-01 01:00 LinSwap
drwxr-xr-x 2 root root 4096 2005-06-01 20:09 VIDEO
root@Kubuntu:/mnt #

notice that now the whole filesystem belongs to me and only i can write to it and view it. although this works it is really messy, what is going on here ?

Mike Smile
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
Nigel
LXF regular


Joined: Fri Apr 08, 2005 9:03 pm
Posts: 1141
Location: Gloucestershire, UK

PostPosted: Sat Jun 04, 2005 11:05 am    Post subject: RE: External USB HDD Reply with quote

Try doing a chmod 777 on /mnt/LACIE before you mount the disk...
then try
mount -t vfat -o rw /dev/sdb1 /mnt/LACIE
_________________
Hope this helps,

Nigel.
Back to top
View user's profile Send private message
youlikeicecream
LXF regular


Joined: Fri Jun 03, 2005 12:40 pm
Posts: 721
Location: Oxford

PostPosted: Sat Jun 04, 2005 8:28 pm    Post subject: RE: External USB HDD Reply with quote

tried that and this was result

root@Kubuntu:/mnt # ls -la
total 48
drwxr-xr-x 6 root root 4096 2005-06-02 00:25 .
drwxr-xr-x 22 root root 4096 2005-06-01 18:38 ..
drwxrwxr-x 2 root root 4096 2005-06-02 00:25 LACIE
drwxr-xr-x 4 root root 16384 1970-01-01 01:00 LinMusic
drwxr-xr-x 5 root root 16384 1970-01-01 01:00 LinSwap
drwxr-xr-x 2 root root 4096 2005-06-01 20:09 VIDEO
root@Kubuntu:/mnt # chmod 777 LACIE
root@Kubuntu:/mnt # ls -la
total 48
drwxr-xr-x 6 root root 4096 2005-06-02 00:25 .
drwxr-xr-x 22 root root 4096 2005-06-01 18:38 ..
drwxrwxrwx 2 root root 4096 2005-06-02 00:25 LACIE
drwxr-xr-x 4 root root 16384 1970-01-01 01:00 LinMusic
drwxr-xr-x 5 root root 16384 1970-01-01 01:00 LinSwap
drwxr-xr-x 2 root root 4096 2005-06-01 20:09 VIDEO
root@Kubuntu:/mnt # mount -t vfat -o rw /dev/sdb1 /mnt/LACIE
root@Kubuntu:/mnt # ls -la
total 76
drwxr-xr-x 6 root root 4096 2005-06-02 00:25 .
drwxr-xr-x 22 root root 4096 2005-06-01 18:38 ..
drwxr-xr-x 9 root root 32768 1970-01-01 01:00 LACIE
drwxr-xr-x 4 root root 16384 1970-01-01 01:00 LinMusic
drwxr-xr-x 5 root root 16384 1970-01-01 01:00 LinSwap
drwxr-xr-x 2 root root 4096 2005-06-01 20:09 VIDEO
root@Kubuntu:/mnt #

i give up .. will not use it the drive as I wanted to
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
skecs



Joined: Fri Apr 22, 2005 10:22 am
Posts: 76
Location: Bathurst, NSW Australia

PostPosted: Sun Jun 05, 2005 4:07 am    Post subject: RE: External USB HDD Reply with quote

Can you paste your /etc/fstab file?

I can remember having a similar problem mounting vfat partitions and changing the mount permissions (where it is just defaults) to include "rw,users" fixed the problem. Note the "s" on users - this allows users to mount the device.

I'm looking for my old details on fstab config - it's here somewhere Rolling Eyes
_________________
Regards from
Downunder!
.... _
... (0)>
... / /\
.. / / .)
.. V_/_
Linux Powered!
Back to top
View user's profile Send private message
youlikeicecream
LXF regular


Joined: Fri Jun 03, 2005 12:40 pm
Posts: 721
Location: Oxford

PostPosted: Sun Jun 05, 2005 8:55 am    Post subject: RE: External USB HDD Reply with quote

/etc/fstab ....
(had to comment out LACIE for device to work from device icon on desktop)

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hdb1 / ext3 defaults,errors=remount-ro 0 1
/dev/hdb9 /home ext3 defaults 0 2
/dev/hda10 /mnt/LinMusic vfat defaults 0 0
/dev/hdb10 /mnt/LinSwap vfat defaults 0 0
#/dev/sdb1 /mnt/LACIE vfat defaults 0 0
/dev/hdb7 /tmp ext3 defaults 0 2
/dev/hdb6 /usr ext3 defaults 0 2
/dev/hdb8 /var ext3 defaults 0 2
/dev/hda6 none swap sw 0 0
/dev/hdb5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

thanks Smile
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
youlikeicecream
LXF regular


Joined: Fri Jun 03, 2005 12:40 pm
Posts: 721
Location: Oxford

PostPosted: Sun Jun 05, 2005 8:56 am    Post subject: RE: External USB HDD Reply with quote

have recently noticed that I am also experiencing the same problems with the other two fat partitions, can't write to them also
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
skecs



Joined: Fri Apr 22, 2005 10:22 am
Posts: 76
Location: Bathurst, NSW Australia

PostPosted: Sun Jun 05, 2005 10:35 am    Post subject: RE: External USB HDD Reply with quote

I'm sure (do a man 5 fstab & man 8 mount at the terminal for more information) that with the three vfat devices you should change "defaults" to "rw,user,auto" and they should be mounted at boot time. If the LaCie drive isn't attached all the time change it to noauto.

Do this and reboot to flush everything and have /etc/fstab read again and it should work. The "defaults" settings are "rw, suid, dev, exec, auto, nouser, and async" which doesn't allow users to mount those devices/file systems.

Hope this helps.
_________________
Regards from
Downunder!
.... _
... (0)>
... / /\
.. / / .)
.. V_/_
Linux Powered!
Back to top
View user's profile Send private message
youlikeicecream
LXF regular


Joined: Fri Jun 03, 2005 12:40 pm
Posts: 721
Location: Oxford

PostPosted: Sun Jun 05, 2005 10:54 am    Post subject: RE: External USB HDD Reply with quote

I think thats what Mandriva did in fstab and it worked, will try in a mojo.

cheers ta Smile
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
youlikeicecream
LXF regular


Joined: Fri Jun 03, 2005 12:40 pm
Posts: 721
Location: Oxford

PostPosted: Sun Jun 05, 2005 11:03 am    Post subject: RE: External USB HDD Reply with quote

Okay so tried that, pasting etc/fstab but still didn't work. Root is the owner but LinSwap and LinMusic are still writeabl;e for root only (World/Group readeable) and the LACIE wasn't even mounted.

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hdb1 / ext3 defaults,errors=remount-ro 0 1
/dev/hdb9 /home ext3 defaults 0 2
/dev/hda10 /mnt/LinMusic vfat rw,user,auto 0 0
/dev/hdb10 /mnt/LinSwap vfat rw,user,auto 0 0
/dev/sdb1 /mnt/LACIE vfat rw,user,auto 0 0
/dev/hdb7 /tmp ext3 defaults 0 2
/dev/hdb6 /usr ext3 defaults 0 2
/dev/hdb8 /var ext3 defaults 0 2
/dev/hda6 none swap sw 0 0
/dev/hdb5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 udf,iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
M0PHP
LXF regular


Joined: Wed Apr 06, 2005 8:40 am
Posts: 737
Location: Bishop Auckland, County Durham, UK

PostPosted: Sun Jun 05, 2005 11:56 am    Post subject: Reply with quote

Don't know if this will work on a vfat partition but it's worth a go.

To allow other users to write, do this before mounting as pointed out previously in the thread.

# chmod 777 /mnt/LACIE
# ls -l /mnt|grep LACIE

That should give you drwxrwxrwx for LACIE, iirc.

Mount it, then do:

# chmod -R 777 /mnt/LACIE
(might take a while if its a big disk)
# ls -l /mnt|grep LACIE

(and it should be drwxrwxrwx again)

# ls -l /mnt/LACIE

You should now have (d)rwxrwxrwx under /LACIE and all of its subfolders and files.
Back to top
View user's profile Send private message Visit poster's website
youlikeicecream
LXF regular


Joined: Fri Jun 03, 2005 12:40 pm
Posts: 721
Location: Oxford

PostPosted: Sun Jun 05, 2005 11:58 am    Post subject: Reply with quote

this has been tried before and after mounting. could it be because i have made the 160GB Lacie drive a single 157GB Primary FAT32 Partition, should it hav been a logical partition ?

Mike Smile
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
M0PHP
LXF regular


Joined: Wed Apr 06, 2005 8:40 am
Posts: 737
Location: Bishop Auckland, County Durham, UK

PostPosted: Sun Jun 05, 2005 12:00 pm    Post subject: Reply with quote

Have you already ran chmod -R after mounting to make all the directories on the disk 777?

Hmm.. no Mike, that shouldn't affect it at all.
Back to top
View user's profile Send private message Visit poster's website
youlikeicecream
LXF regular


Joined: Fri Jun 03, 2005 12:40 pm
Posts: 721
Location: Oxford

PostPosted: Sun Jun 05, 2005 12:05 pm    Post subject: Reply with quote

tried it, yeah
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
M0PHP
LXF regular


Joined: Wed Apr 06, 2005 8:40 am
Posts: 737
Location: Bishop Auckland, County Durham, UK

PostPosted: Sun Jun 05, 2005 12:08 pm    Post subject: Reply with quote

Well, I don't know what else to suggest Confused
Back to top
View user's profile Send private message Visit poster's website
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast