Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Monodevelop Runtime 2.0 doesn't complie

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Programming
View previous topic :: View next topic  
Author Message
moeFinley



Joined: Sun Jan 28, 2007 4:44 pm
Posts: 4

PostPosted: Sun Jan 28, 2007 4:53 pm    Post subject: Monodevelop Runtime 2.0 doesn't complie Reply with quote

I using Edgy and Monodevelop 0.12

I have an application that compiles and runs fine using runtime version 1.1 but as soon as I switch to 2.0 it would create an .exe

There are no errors when it compiles but when I try and run it I get
Code:
cannot open assembly

and there is not .exe in the output folder?

I'm just starting to learn Mono so I'm sure I might be doing something wrong but I don't know what. Could any help shed any light? Thanks
Back to top
View user's profile Send private message
tjelle



Joined: Fri Jan 19, 2007 5:28 pm
Posts: 10

PostPosted: Fri Feb 02, 2007 5:20 pm    Post subject: RE: Monodevelop Runtime 2.0 doesn Reply with quote

I got the same problem (ubuntu 6.10 edgy), when trying out the mono tutorial in LFX88.

Was wondering if it had to do with the version of mono installed on ubuntu: mono (1.1.17.1-1ubuntu7.1)?

Does anyone know?
Back to top
View user's profile Send private message
moeFinley



Joined: Sun Jan 28, 2007 4:44 pm
Posts: 4

PostPosted: Fri Feb 02, 2007 6:57 pm    Post subject: Reply with quote

Sorry, someone posted the solution on the Ubuntu Forums and I should have duplicated it here. You need to install the 2.0 complier.

Code:
sudo apt-get install mono-gmcs


Here is a link to the Ubuntu Forums Post
http://ubuntuforums.org/showthread.php?t=348140

Hope this helps
Back to top
View user's profile Send private message
tjelle



Joined: Fri Jan 19, 2007 5:28 pm
Posts: 10

PostPosted: Sat Feb 03, 2007 1:05 pm    Post subject: Reply with quote

Thanks, it works now. Smile
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast