Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Configuration - ARGHHH!

 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
Birdman
LXF regular


Joined: Thu May 05, 2005 12:59 pm
Posts: 145
Location: Wallington, Surrey UK

PostPosted: Thu Jun 30, 2005 1:00 pm    Post subject: Configuration - ARGHHH! Reply with quote

Don't you just hate those evenings when you settle down to do a nice bit of configuration, you've done it all before so should be nice and easy - AND NOTHING GOES RIGHT.

Printer HP DeskJet 5150

What could be easier. Done it all before. Been to www.linuxprinting.org to see if there was anything new I should know about, checked what was already installed i.e. the HP drivers package. Went into the CUPS web interface and installed a new printer. Printer is there ready for action. Turn on printer and click on "Print test page". Spool entry - no print. Cancelled the print and noticed the CUPS status for the printer saying that the printer was not connected and it would try again in 30 seconds. I stopped the printer and restarted it and the status said it was idle and ready to receive jobs. Circle complete - lets repeat it another half dozen times Rolling Eyes Tried using lp, lpq and lprm all to the same end. On the surface it looks like everything is working fine, but it isn't. The printer even shows as being installed when I have a look in spadmin for OOo Confused

I am probably missing the obvious. Ring any bells with anyone?

Network connection

If I boot from cold I see all the DHCP negotiations on the boot screens and the network comes up with no problems. If I do a soft reboot I lose my connection. The only way I can get it back is to shut down the PC and start up again from cold. If I am soft rebooting from WinXP into linux it works fine. I assume that my new linux kernel is not shutting down the network connection correctly so that a new connection can be established? I have never had this problem with my 2.4 kernel.

OOo fonts.

My old install had OOo 1.1 and I made soft links with the win9x fonts. Dead easy. I now have WinXP and have installed OOo 2.0 pre that came on the LXF cover a few months ago. If I follow the above procedure it does not work Confused

I love it really Wink
Back to top
View user's profile Send private message
Birdman
LXF regular


Joined: Thu May 05, 2005 12:59 pm
Posts: 145
Location: Wallington, Surrey UK

PostPosted: Sat Jul 02, 2005 3:36 pm    Post subject: RE: Configuration - ARGHHH! Reply with quote

My print settings were spot on. I didn't have a usb sub-system Embarassed On rechecking my .config I found that I had selected uhci and not ohci. Amazing what difference an o makes Wink

One down, two to go.

BTW: Soft rebooting out of WinXP into linux does have the same affect on the network connection ie. I lose it. This never happened with my 2.4 kernel. I am very curious about this one.
Back to top
View user's profile Send private message
A-Wing
LXF regular


Joined: Tue Jul 05, 2005 8:25 pm
Posts: 460
Location: Wellingborough

PostPosted: Tue Jul 05, 2005 9:15 pm    Post subject: RE: Configuration - ARGHHH! Reply with quote

With regard to Network connection I have seen similar things in Ubuntu with Ndiswrapper, but not Fedora with the same version of Ndiswrapper with the same driver. I am guessing the driver isn't unloaded cleanly on shutdown, there may well be a fix for it but I couldn't tell you without knowing what network card you are using.
Can't really help with the OOo issue but I'm sure it will be a common problem that will google easy or be on a FAQ page at OOo.
_________________
Andrew Hutchings, Linux Jedi
www.a-wing.co.uk
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Birdman
LXF regular


Joined: Thu May 05, 2005 12:59 pm
Posts: 145
Location: Wallington, Surrey UK

PostPosted: Tue Jul 05, 2005 11:09 pm    Post subject: RE: Configuration - ARGHHH! Reply with quote

A-Wing said
>
Can't really help with the OOo issue but I'm sure it will be a common problem that will google easy or be on a FAQ page at OOo.
>
Well, neally sorted this one. I forgot to run fc-cache. If I launch soffice as root all the fonts are there Very Happy
However, as a user the fonts are not there Sad There something wierd happening with all things windows partitions. Natuarally, my NTFS Windows system partition is read only - this is where the fonts are. I am not wishing to write anything there, so why root can see the fonts and users cannot I am really not sure, Just as strange, I have a Windows data partition that is FAT32 and has read write access given to users ( I have the same /etc/fstab entries as my previous installation) but I cannot write to the partition other than as root. Very strange.
Back to top
View user's profile Send private message
A-Wing
LXF regular


Joined: Tue Jul 05, 2005 8:25 pm
Posts: 460
Location: Wellingborough

PostPosted: Tue Jul 05, 2005 11:22 pm    Post subject: RE: Configuration - ARGHHH! Reply with quote

See: http://linux-ntfs.sourceforge.net/info/ntfs.html#4.6

The UMASK options should sort this out for you.
_________________
Andrew Hutchings, Linux Jedi
www.a-wing.co.uk
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Birdman
LXF regular


Joined: Thu May 05, 2005 12:59 pm
Posts: 145
Location: Wallington, Surrey UK

PostPosted: Wed Jul 06, 2005 9:30 am    Post subject: Re: RE: Configuration - ARGHHH! Reply with quote

A-Wing wrote:
See: http://linux-ntfs.sourceforge.net/info/ntfs.html#4.6

The UMASK options should sort this out for you.


A-Wing, thanks. That is a really good info source to know about.

I have just made a quick change to the fstab for my FAT32 (rw) partition:

/dev/sda6 /mnt/windata vfat rw,gid=100,umask=0000

The gid is for users and the umask should give a 777 permissions set. I have made the change and remounted the partition and I still get the error:

cp: cannot create regular file `/mnt/windata/Alan/Helicopter.pps': Permission denied

BTW I am set-up as alan.users as my standard /home config.

On the network problem, it is nothing to do with rebooting. I switched on cold this morning and had no network. A shutdown and start again got me in. However, I have this message in the syslog:

Jul 6 08:47:57 avocet dhcpcd[4406]: dhcpStart: interface eth0 is not Ethernet or 802.2 Token Ring

I guess this is the clue. If only I new what it meant
Confused
Back to top
View user's profile Send private message
A-Wing
LXF regular


Joined: Tue Jul 05, 2005 8:25 pm
Posts: 460
Location: Wellingborough

PostPosted: Wed Jul 06, 2005 9:54 am    Post subject: RE: Re: RE: Configuration - ARGHHH! Reply with quote

It looks as though the umask you have given is blocking access. You want something like 0555 I think, or maybe 0550 in your case..

hmm....that tends to suggest the eth0 driver didn't load correctly, or bad cabling. What card is it? Is it on a hub/switch?
Are you able to give us a copy of dmesg at eth0 driver load time next time it fails?
_________________
Andrew Hutchings, Linux Jedi
www.a-wing.co.uk
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
jimsaku



Joined: Tue Jun 28, 2005 9:52 pm
Posts: 15

PostPosted: Wed Jul 06, 2005 6:27 pm    Post subject: Re: RE: Re: RE: Configuration - ARGHHH! Reply with quote

A-Wing wrote:
It looks as though the umask you have given is blocking access. You want something like 0555 I think, or maybe 0550 in your case..


aye, it's easy to forget that umask is the reverse of the permissions you *want* Smile

with regard to the network connection, does it ever fail to start if you boot straight into XP from cold, like it has for linux? if so, you may want to check your BIOS settings, or maybe check the settings of the DHCP server (if you can).


jim.
Back to top
View user's profile Send private message
Birdman
LXF regular


Joined: Thu May 05, 2005 12:59 pm
Posts: 145
Location: Wallington, Surrey UK

PostPosted: Wed Jul 06, 2005 9:42 pm    Post subject: RE: Re: RE: Re: RE: Configuration - ARGHHH! Reply with quote

A-Wing this doesn't make sense to me. If I am applying a mask that inverts the normal permissions then doesn't 000 = 777 i.e. if I want wrxwrxwrx then 000 is what it should be? I have just tried 1111, in other word wr-wr-wr- but that still says Permission denied Sad

On the network side here is the section from dmesg for a working set-up:

8139too Fast Ethernet driver 0.9.27
ACPI: PCI interrupt 0000:00:0c.0[A] -> GSI 18 (level, low) -> IRQ 18
eth0: RealTek RTL8139 at 0xcc00, 00:01:6c:aa:05:b8, IRQ 18
eth0: Identified 8139 chip type 'RTL-8100B/8139D'
kjournald starting. Commit interval 5 seconds
EXT3 FS on sda1, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
NTFS volume version 3.1.
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1

As you can see, the onboard chip is a Real Tek and the module that is loaded is 8139too.

My box is connected to a hub-switch that is connected to a Smoothwall box and then to my ethernet cable modem. So yes, the DHCP handshaking stuff has to succeed for a connection to be made.

jimsaku - I have no problems with WinXP negotiating a connection. This has only been a problem since I compiled my own custom 2.6 kernel (Slackware only ships with 2.4 kernels currently). I guess I need to tweak something to perhaps allow a bit more time for the dhcp lease to be negotiated?

I'll force the error with a soft reboot and see what I can find to report in the dmesg.

Thanks for the input.
Back to top
View user's profile Send private message
Birdman
LXF regular


Joined: Thu May 05, 2005 12:59 pm
Posts: 145
Location: Wallington, Surrey UK

PostPosted: Wed Jul 06, 2005 10:17 pm    Post subject: RE: Re: RE: Re: RE: Configuration - ARGHHH! Reply with quote

Very interesting!

Tests completed:

Broken system:

#dmesg | grep -i eth

eth1394: $Rev: 1224 $ Ben Collins <bcollins@debian.org>
eth1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
8139too Fast Ethernet driver 0.9.27
eth1: RealTek RTL8139 at 0xcc00, 00:01:6c:aa:05:b8, IRQ 18
eth1: Identified 8139 chip type 'RTL-8100B/8139D'

Working system:

#dmesg | grep -i eth
8139too Fast Ethernet driver 0.9.27
eth0: RealTek RTL8139 at 0xcc00, 00:01:6c:aa:05:b8, IRQ 18
eth0: Identified 8139 chip type 'RTL-8100B/8139D'
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
eth0: no IPv6 routers present

The line that appears on the screen when the network fails is not reported in dmesg but gets hived off into the /var/log/syslog:

dhcpcd[4406]: dhcpStart: interface eth0 is not Ethernet or 802.2 Token Ring

For some reason, my Real Tek is assigned to eth1 if the connection fails and this throws the dhcp server out of sync. I sort of see what is happening but do not understand why or what I can do about it?

Ah ah, just noticed that there may be some sort of conflict going on with the firewire - it shows in the broken connection but not the working one. I do not have any firewire stuff so perhaps disabling this might be a temporary solution?

Perhaps not. just did:

sh-3.00$ dmesg | grep -i 1394
ieee1394: Initialized config rom entry `ip1394'
ohci1394: $Rev: 1223 $ Ben Collins <bcollins@debian.org>
ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[19] MMIO=[e6084000-e60847ff] Max Packet=[2048]
ieee1394: raw1394: /dev/raw1394 device initialized
ieee1394: Host added: ID:BUS[0-00:1023] GUID[00016c200008aec9]

It looks like the firewire stuff is loaded, but in a totally different way?
Back to top
View user's profile Send private message
A-Wing
LXF regular


Joined: Tue Jul 05, 2005 8:25 pm
Posts: 460
Location: Wellingborough

PostPosted: Wed Jul 06, 2005 10:50 pm    Post subject: RE: Re: RE: Re: RE: Configuration - ARGHHH! Reply with quote

dmesg, always a good friend to have.
I have no experiance on firewire unfortunately. I am guessing it pretends it has a network connected and load appropriate driver (I think I used to see this on Windows machines with firewire), but then you would think it would do it on every boot. Maybe there is a BIOS patch to fix this?
_________________
Andrew Hutchings, Linux Jedi
www.a-wing.co.uk
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Birdman
LXF regular


Joined: Thu May 05, 2005 12:59 pm
Posts: 145
Location: Wallington, Surrey UK

PostPosted: Mon Jul 11, 2005 11:39 pm    Post subject: RE: Re: RE: Re: RE: Configuration - ARGHHH! Reply with quote

Got the network problem sorted Smile Probably not the ideal solution but at least I have a result.

I evaluated that the ether1384 module was grabbing eth0 and that meant my "real" eth0 was being assigned to eth1 but the dhcpd was not looking at that device for a network connection. Having then examined my .config file I found that indeed I had selected for a 1384 ethernet module to be created. I removed this from the .config and recompiled the kernel. So far so good.
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast