Debian 3.1 Problems

Comments, suggestions and questions about Linux Format magazine and the coverdiscs

Moderators: ChrisThornett, LXF moderators

Debian 3.1 Problems

Postby Mr_Fish » Thu Aug 18, 2005 1:49 pm

I'm rather new to Linux, but I've dabbled now and again in the past. I thought I'd try-out Debian after enjoying using a live cd of Ubuntu. I've run across a few problems however.

First, my screen resolution won't go any higher than 800x600, yet I know my LCD's default rez is 1280x1024. I'm assuming this might have something to do with my ATI Radion 9000 gfx card. Am I right in saying that ATI and Linux don't play well together? Strange that Ubuntu set it up correctly though...

Second. I'm not sure, but I think my soundcard may not be working either. It's a Soundblaster Audigy.

Third. Despite setting it up during the installation, it seems my keyboard is set to an American layout. I found this out when I tried to register here and couldn't find "@".

I'd also like to mention that I tried to install Debian four times before I realised that I needed to press the space bar at the package selection page. Being dropped at a rather unfriendly command prompt was disheartening to say the least. But still, I got there eventually and now I'd just like to sort-out these little niggles.

TIA
Mr_Fish
 
Posts: 2
Joined: Thu Aug 18, 2005 1:38 pm

RE: Debian 3.1 Problems

Postby Erin » Thu Aug 18, 2005 8:27 pm

1) You probably need to set-up the monitor correctly or/and get the ATi drivers from their website.

2) Try opening a mixer application or go to a console and type "alsamixer" as often cards are just muted for no rhyme or reason.

3) In GNOME the setting is in the preferences menu somewhere - I remember not where, I found I had to uninstall lots of US stuff and install GB files instead for dictionaries and the like.

4) Debian is not the most newbie friendly distro there is. Congratulations for trying one of the better distros first but it will take a little learning. Feel free to ask us how to do things if/when you get stuck.

erin
Just beneath my skin I'm screaming. Faithless::Insomnia.
Dual PIII 550 with Ubuntu [semi-bleeding].
User avatar
Erin
LXF regular
 
Posts: 141
Joined: Thu Apr 07, 2005 7:35 pm
Location: The Olde Smoke south of the River

RE: Debian 3.1 Problems

Postby towy71 » Thu Aug 18, 2005 9:42 pm

if you're using kde there should be a little usflag icon in the bottom right hand tool bar, if you right click and choose configure you should be able to pick the uk option and move it to the top of the list, and even remove the american option too

HTH
Dick
oh and I echo Erin on point 4 ;-)
still looking for that door into summer
User avatar
towy71
Moderator
 
Posts: 4267
Joined: Wed Apr 06, 2005 2:11 pm
Location: wild West Wales

Postby Mr_Fish » Fri Aug 19, 2005 11:17 am

I eventually got a "proper" screen resolution by entering

dpkg-reconfigure xserver-xfree86


(Google is your friend!) and re-running the xserver setup. Seemed to cure my keyboard problems as well.

I installed a newer kernel to see if that would give me sound, but unfortunately not. Considerably speeded up my boot time though.

I like what I've seen, but I've also been playing with an Ubuntu live CD, and I think I like that better. For a start, everything just... worked. Just hope the full installation is the same.

Thanks.
Mr_Fish
 
Posts: 2
Joined: Thu Aug 18, 2005 1:38 pm


Return to Magazine and coverdiscs

Who is online

Users browsing this forum: No registered users and 0 guests