Linux Format forums Forum Index Linux Format forums
Help, discussion, magazine feedback and more
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Slow broadband....
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help!
View previous topic :: View next topic  
Author Message
Dark_Willow



Joined: Tue Aug 09, 2005 10:10 pm
Posts: 5
Location: UK

PostPosted: Thu Aug 18, 2005 6:12 pm    Post subject: Slow broadband.... Reply with quote

Just installed Mandriva Linux with KDE on my laptop connected to Telewest 512k cable via a Motorola Surfboard 5100i cable modem (USB or Ethernet). This is connected throug it's ehternet port to the laptop via a Sitecom LN-029 USB to Ethernet adapter. Web browser in use are FireFox and Konquror.

The installation (very nice) set up the system excellently and found all hardware including the USB adaptor which it has set as ETH0.

However the effective download speeds are much slower than with my Win2k Pro setup (same system, different H/D). When browsing the web, there is a long lag before a connection is established with a site, then downloads is fast but sporadic, with very long pauses. Are there any firmware updates or drivers I need?

Also, are there any plug in available for linux versions of firefox to play QuickTime or Windows Media files?
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
linuxgirlie
LXF regular


Joined: Sat Apr 09, 2005 7:34 pm
Posts: 787
Location: Kent...UK

PostPosted: Thu Aug 18, 2005 7:00 pm    Post subject: RE: Slow broadband.... Reply with quote

I find konqueror very fast, verus firefox. Do you have an kb per second speeds?
_________________
My knowledge comes with no warranty...........

Server operating system designed for schools:www.linuxschools.com
Back to top
View user's profile Send private message Send e-mail
mugstar
LXF regular


Joined: Mon Apr 11, 2005 1:43 am
Posts: 184
Location: Scotland

PostPosted: Thu Aug 18, 2005 8:21 pm    Post subject: Reply with quote

If it's not a hardware issue, then there are some very effective tweaks for Firefox on the Gentoo forums: http://tinyurl.com/8u7aj
Back to top
View user's profile Send private message
Dark_Willow



Joined: Tue Aug 09, 2005 10:10 pm
Posts: 5
Location: UK

PostPosted: Thu Aug 18, 2005 9:45 pm    Post subject: Reply with quote

I'm not sure that it's a FireFox problem, as I have the same problem with Konqueror. The actual data transnfer speed I get are fine, typically around 65 to 80 kbps. However the problem is when looking up domains, the browser takes 30 sec or so to look up a domain, wheras on Win2k (using Firefox) the responce is in most cases just a few secs at most.
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8457
Location: Warrington, UK

PostPosted: Thu Aug 18, 2005 11:36 pm    Post subject: Reply with quote

Compare the DNS servers you are using with Windows and Linux, for Linux you'll find this information in /etc/resolv.conf.
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
nordle
LXF regular


Joined: Fri Apr 08, 2005 10:56 pm
Posts: 1500

PostPosted: Fri Aug 19, 2005 12:10 am    Post subject: Reply with quote

Sounds very similar to a problem I, and many others, had a while ago, which was down to IPV6

I can't remember at all what was done to fix it, remove some lines from a conf file somewhere, does anyone else remember what Im babling about?

Same thing, took AGES to connect to a site, once hooked up it downloaded fine, nice and quick.
_________________
I think, therefore I compile
Back to top
View user's profile Send private message
Dark_Willow



Joined: Tue Aug 09, 2005 10:10 pm
Posts: 5
Location: UK

PostPosted: Fri Aug 19, 2005 10:20 am    Post subject: Reply with quote

nordle wrote:
Sounds very similar to a problem I, and many others, had a while ago, which was down to IPV6

I can't remember at all what was done to fix it, remove some lines from a conf file somewhere, does anyone else remember what Im babling about?

Same thing, took AGES to connect to a site, once hooked up it downloaded fine, nice and quick.


Sounds exactly like problem I have here, so if anyone can remeber what to do, pls enlighten!
Back to top
View user's profile Send private message Visit poster's website Yahoo Messenger
nordle
LXF regular


Joined: Fri Apr 08, 2005 10:56 pm
Posts: 1500

PostPosted: Sat Aug 20, 2005 1:52 am    Post subject: Reply with quote

Have a look in /etc/modprobe.conf, comment out any lines which mention IPV6

eg

# this line is commented out, ie won't have any effect
this line is not commented out, so will have an effect

Apologies if getting too detailed, no idea what you know etc

You will need to reboot....well, strictly speaking you don't, but I have no idea which startup scripts need to re-run, so booting is all I can think of Smile
Back to top
View user's profile Send private message
jer1ch0
LXF regular


Joined: Sat Apr 09, 2005 11:42 am
Posts: 135
Location: Ireland

PostPosted: Sun Aug 21, 2005 11:57 pm    Post subject: Reply with quote

not sure what it is in Mandriva, but in ubuntu or SuSE,
1. sudo gedit /etc/modprobe.d/aliases
2. Find the line: alias net-pf-10 ipv6
3. Edit this to: alias net-pf-10 off
4. Save the file and reboot
Your browsing should now be a lot faster.

Also: Here's something for broadband people that will really speed Firefox up:



1.Type "about:config" into the address bar and hit return. Scroll down and look for the following entries:



network.http.pipelining network.http.proxy.pipelining network.http.pipelining.maxrequests



Normally the browser will make one request to a web page at a time. When you enable pipelining it will make several at once, which really speeds up page loading.



2. Alter the entries as follows:



Set "network.http.pipelining" to "true"



Set "network.http.proxy.pipelining" to "true"



Set "network.http.pipelining.maxrequests" to some number like 30. This means it will make 30 requests at once.



3. Lastly right-click anywhere and select New-> Integer. Name it "nglayout.initialpaint.delay" and set its value to "0". This value is the amount of time the browser waits before it acts on information it receives.



If you're using a broadband connection you'll load pages MUCH faster now!
Back to top
View user's profile Send private message Visit poster's website
Gordon
LXF regular


Joined: Thu Apr 07, 2005 6:01 pm
Posts: 209
Location: Bradford, West Yorkshire

PostPosted: Mon Aug 22, 2005 5:58 pm    Post subject: Reply with quote

Thanks for that firefox. It really does work Very Happy

Gordon
_________________
Violence is the last refuge of the incompetent
Back to top
View user's profile Send private message Yahoo Messenger
towy71
Moderator


Joined: Wed Apr 06, 2005 3:11 pm
Posts: 4259
Location: wild West Wales

PostPosted: Mon Aug 22, 2005 7:36 pm    Post subject: Reply with quote

jer1ch0
you are a star, this has made it much faster! Very Happy Very Happy Very Happy

thanks my friend

Dick
_________________
still looking for that door into summer
Back to top
View user's profile Send private message
RD
LXF regular


Joined: Mon Jul 25, 2005 3:53 am
Posts: 272
Location: irc.ixl2.net

PostPosted: Mon Aug 22, 2005 7:45 pm    Post subject: Reply with quote

both work Very Happy on kubuntu
_________________
[url=irc://irc.ixl2.org/ixl2]irc.ixl2.org[/url]
Back to top
View user's profile Send private message Visit poster's website
mugstar
LXF regular


Joined: Mon Apr 11, 2005 1:43 am
Posts: 184
Location: Scotland

PostPosted: Mon Aug 22, 2005 8:50 pm    Post subject: Reply with quote

*ahem, cough, cough*
...as do all the other ones in the link I posted above... Rolling Eyes
<slinks off in huff...>
Wink
Back to top
View user's profile Send private message
RD
LXF regular


Joined: Mon Jul 25, 2005 3:53 am
Posts: 272
Location: irc.ixl2.net

PostPosted: Tue Aug 23, 2005 12:18 am    Post subject: Reply with quote

IMO

I think this thread should be made a sicky for new users
_________________
[url=irc://irc.ixl2.org/ixl2]irc.ixl2.org[/url]
Back to top
View user's profile Send private message Visit poster's website
nelz
Site admin


Joined: Mon Apr 04, 2005 12:52 pm
Posts: 8457
Location: Warrington, UK

PostPosted: Tue Aug 23, 2005 12:56 am    Post subject: Reply with quote

For when a newbie wants a day off? Laughing
_________________
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
Back to top
View user's profile Send private message
View previous topic :: View next topic  
Display posts from previous:   
Post new topic   Reply to topic    Linux Format forums Forum Index -> Help! All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Linux Format forums topic RSS feed 


Powered by phpBB © 2001, 2005 phpBB Group


Copyright 2011 Future Publishing, all rights reserved.


Web hosting by UKFast