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Our 
expert Transport controls

These big buttons control the 

playback, recording and navigation 

of audio files. You’ll find, from left 

to right, pause, play, stop, skip to 

start, skip to end and record.

Faders
Control the input and output 

volume of your tracks and select 

the source for your original. 

The Audacity interface

Secondary toolbar
Contains cut, copy and paste 

buttons as well as a slider to 

slow down or speed up playback. 

Main toolbar 
This is where you’ll find the most 

important tools for manipulating 

selected areas of a track.

Monitors
The monitor section gives you a 

visual impression of how loud your 

recording or playback is. 

Editing window
What you see will change 

depending upon the tool selected. 

To the left of the waveform (the 

blue peaky thing) are the track 

options, including track volume and 

pan, and mute/solo buttons – these 

are mostly used when working on 

multitrack projects.

First Steps:  Rip     

Andy 
Channelle
Andy has been 
taking his first 
steps in Linux 
software for the 
past six years and 
has been interested 
in technology since 
the advent of the 
Dragon 32. 

Records are making a comeback, inspiring Andy Channelle to begin 
ripping his collection of vinyl to the computer for the first time...

First Steps Beginner-level tutorials for 
users dipping their toes into Linux

T
he musical lives of most people over the age of 30 can be 

divided into two parts: pre- and post-CD. This point, usually 

in the mid to late 80s, marks the moment when they 

stopped buying music on large black discs with impressive sleeve 

art that could double up as teen-friendly wall decoration and, 

instead, began to acquire small shiny silver platters that came 

with uninspiring ‘booklets’ and the potential for 72 minutes of 

music (hence the term ‘filler’). Many people decided that this was 

the ideal opportunity to re-buy all of their music on said discs so 

they could listen to them on micro hi-fi systems. For some, though, 

spending money on something they already owned seemed a bit 

of a con, and for others the music they had spent years collecting 

may not have been available on CD. The transition to music files 

such as MP3 and OGG was a bit easier for CD users, but vinyl fans 

were once again offered the opportunity to pay for their music a 

second time to play it on their computers, iPods etc.

There is a better solution than repeatedly paying for things that 

you already own, and it doesn’t take a lot of expensive equipment. 

You will, however, need a turntable, a soundcard and a lead to 

connect the two together. Most mass-market turntables have 

phono connectors, while most soundcards have mini jack sockets, 

so a phono to jack converter may also be required (you should be 

able to get them from any electrical outlet). Software 

Last month Really Simple Syndication made even simpler, with our intro to RSS
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 MP3s from vinyl

If you missed last issue Call 0870 837 4773 or +44 1858 438795.

requirements are even easier, as we’ll be using the excellent open 

source Audacity software. Ripping vinyl may take a little longer 

than ripping CDs, as you have to record in real time, but the 

advantages are that you’ll probably end up rediscovering a bunch 

of great tracks while you do it.

Set up your software
Audacity is probably the best free audio editing package available 

on any platform, and is available as a binary for various Linux 

distributions, as well as for OS X and Windows. The Audacity 

website (http://audacity.sourceforge.net) has the latest stable 

and development binaries available, and installation is usually just 

a case of downloading, decompressing and putting the files into a 

folder. You’ll most likely find the software included within your 

normal package manager too if you want to use a version 

optimised for your distribution. Currently the stable version of the 

software is 1.2.6, but the more adventurous could opt for the 

development version, which is currently at version 1.3.4. 

Regardless of your version choice, you should still be able to follow 

this tutorial, as the core tools have not changed significantly 

between these versions. We will, however, be using the stable 

branch of the software, and would recommend you follow suit if 

you want to stay on the tried and tested route.

As we’ll be saving the final files as MP3 files, we may need 

to do a few configuration jobs before we actually get to work on 

the task at hand. The first job is to check whether you have the 

Lame MP3 encoder installed and, if not, to install it. To do the 

former, launch Audacity and then do Edit > Preferences and look 

under the File Formats tab. Under the File Export Setup section 

near the bottom, click on Find Library and look for libmp3lame.so 

or libmp3lame.so.0. Another way to check is to open your file 

manager and look for either /usr/local/lib/libmp3lame.so or 

/usr/lib/libmp3lame.so.

If you don’t find anything using either of these methods, you’ll 

need to install Lame yourself – Audacity doesn’t ship with the 

encoder because of patent issues surrounding the MP3 format. 

The simplest way to do this is to search in your distro’s package 

manager for either LAME or LAME_ENC. In an Ubuntu-based 

distro, you’ll need to launch Synaptic and then go into Settings > 

Repositories and select the option labelled ‘Software restricted by 

legal or copyright issues (multiverse)’. Back in the main search 

engine, enter ‘LAME’, then look for lame and liblame0 and tick the 

box to mark them for installation. Hit the Apply button and let APT 

do its magical stuff. Now close Synaptic, open Audacity and do 

Edit > Preferences one more time. In MP3 Export Setup, choose 

Find Library and hit Yes when asked if you’d like to search for the 

libmp3lame.so (shared object) file. Finally, add ‘.0’ to the filename, 

click through the various warnings and close the dialog box. Now 

you should be able to export MP3 files from within Audacity, and 

we’re ready to begin ripping. However, if you’re using Audacity on 

 You’ll need to install Lame if you want to capture files as 

MP3s for your iPod (other music-playing devices are available).

 Audacity is 

automatically set up 

to check the most 

common locations 

for the file.

 Ubuntu has a slightly convoluted way of accessing MP3 settings, but they are there.
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transport bar and drop the needle. Enjoy. If your computer has a 

fair amount of memory, it’s quite sensible to record one side of an 

album as a single track – we can divide it up later. If, however, 

you’re working on an older machine, it might be worth the extra 

effort to rip each song individually. In this case, wait for the track to 

finish, hit the Stop button and then do File > Save Project As... and 

render the audio to your hard disk. Now do File > Close to close 

the current file, then hit the Record button again, put the needle 

on the record and do the second track. It’s a bit of a pain, but it’s 

worth it in the end. Once side 1 is done and dusted, save your file, 

flip the disc and crack on with side 2.

What we now have is a version of the album in two separate 

tracks that are saved as large .aup files, but what we need is a 

collection of MP3s that we can play with 

Rhythmbox or Amarok.

Open side 1. It’s a good idea to listen to a 

few areas to ensure you have a decent 

recording before you spend the time refining 

things. To do this, use the scroll bar at the 

bottom of the screen to navigate the tracks 

and, using the selection tool, click somewhere in a track and hit 

the Play button. Playback will begin from where you just clicked. 

Seek out areas of high or low volume, as indicated by either very 

wide or narrow bands in the waveform respectively, and play 

through these to check the levels. You can use the zoom tools to 

reveal more of the waveform, so zoom out until you can see some 

individual tracks on the screen; you’ll notice these because there 

should be a few seconds of relative quiet visible on the waveform, 

but be careful not to be caught out by false endings – check if 

you’re unsure. With the selection tool, click and drag your mouse 

from one end of the track to the other, highlighting the waveform 

as you go. Now do File > Export Selection... then save the file as a 

WAV file if you have the space, or as an MP3 if you’re short of 

Ubuntu, there’s one small hoop you’ll need to go through. With a 

file open, select File > Export. If you click on the Options button, 

you’ll notice that there are no options for MP3 encoding, so hit the 

little arrow next to the Browse For Other Folders arrow, use the 

drop-down list at the bottom-right to select MP3, then hit the 

Option button. It should all be there.

On the level
Ripping is not as simple as hitting a button, because the music on 

those big black discs isn’t digital (see Analogue vs Digital boxout, 

below-right). The first step to perfect samples is to ensure that 

your turntable is plugged into the right jack socket and that your 

‘levels’ are correct. Audio equipment usually outputs a line level 

signal, so it needs to be plugged into the Line In connection on 

your soundcard. If you take the audio output from your turntable 

and feed it into the Mic input, the signal will be boosted to such an 

extent that you’ll just end up with hideous noise. Overloading an 

analogue recording can sometimes lead to a fairly pleasant noise 

because of the warmth of the distortion that is introduced into the 

recording; overloading a digital recording leads to a bit-crushing 

mess that only Lou Reed could love. To check your levels, make 

sure the correct input is selected from the drop-down list to the 

right of all the sliders and drop the needle on to your record. Audio 

will be going into your computer, but you won’t hear anything. 

Click on the disclosure arrow next to the microphone icon below 

the meters and select Start Monitoring; now you should hear your 

glorious vinyl coursing through the computer. You’ll also see the 

meters begin to jiggle and dance. Meters are important – watch 

them to make sure that the longest bar doesn’t go red, as this will 

cause clipping on your track. During the bulk of the track, you want 

them to be showing lots of dark green and a thin slither of blue. If 

the meters are consistently showing red or light green you’ll need 

to adjust the signal by turning the volume down on the turntable. 

Beware: lots of older records were mixed to sound good, usually 

without the intention of filling every element of the harmonic 

spectrum, so you should expect lots of peaks and troughs in the 

audio. Try to find the loudest section of an album or song and 

make sure that it doesn’t hit the red.

Now we’re ready to begin ripping, so plug in some decent 

speakers or a pair of headphones, hit the Record button in the 

 Those first two stabs in the waveform are the crackle and pop 

from a badly manufactured (or scratched) vinyl disc.

 By highlighting 

a selection of the 

file, we can ensure 

that any changes 

happen only on 

that part.

 If your audio file looks like this, you really need to lower your 

levels. There’s nothing nice about digital distortion.

“One of the useful things about 
having music in a digital format 
is that we can add metadata.”
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Next month We’ll be creating and editing photo galleries on the web using F-Spot

space. The reason for choosing a WAV format now is that we’ll 

revisit these tracks for a little bit of cleaning up later, and saving in 

a lossless format will mean a better quality MP3 at the end. Do this 

for each of the tracks on both sides of the album and, once you’ve 

finished, delete the original recording.

After 15 years of listening to CDs, the noise that comes from 

vinyl records can be a bit of a shock, so the next stage in the 

process is to clean things up a little by working on individual tracks. 

So do File > Open and bring in the first track from your album. The 

first thing we’re going to do is trim the beginning and end of the 

track to clear away the noise of the needle artlessly hitting 

scratches on the record. With the selection tool, drag across the 

file from the beginning to the point where the music kicks in. Now 

select Generate > Silence and hit the OK button. The formerly 

noisy section will be replaced with a John Cage-esque moment of 

quiet. Now do the same for the end of the song.

If you have a fade out or trailing note at the end of the song, 

judging where it ends can be a pain, so we’re going to engineer a 

fade to complete silence. Highlight the last few seconds of the 

song (or longer if it has a really long fade), then select Effects > 

Fade Out and then do OK. You’ll notice that the waveform changes 

and at the end of the track you have some silence.

You may now find that you have an unnecessarily large gap at 

the start and end of your track. We can get rid of these by 

highlighting the offending region and hitting Delete. Remember, 

though, that you probably want a couple of seconds between each 

track for the purposes of emotional separation (man), so keep 

one second at the beginning and end for this purpose.

If you’re ripping from a cassette you might find the Effect > 

Remove Noise option handy (in which case you’ll want to sample 

a few seconds of fuzz from the beginning of the tape), but 

otherwise we’re going to leave the tracks as they were intended to 

be heard. You could, of course, remaster your entire record 

collection – in which case you’ll want to play with Normalise, 

Compressor, Click Removal and Leveller, which are all under the 

Effect menu, but be aware that you can make very drastic 

changes to the way that the music sounds if you’re not careful.

Ready for output
One of the useful things about having music in a digital format is 

that we can add metadata to the file, which makes managing a 

large collection of music so much easier. To add this information, 

do File > Open Metadata Editor and add as much or as little 

information as you think is required. The bits you’re going to use 

most are the artist and song title, but as with anything, the more 

data you can provide, the easier it is to find later on. When you’re 

finished, hit the Done button to dismiss the dialog box and get 

back to the music. This information will stay with your track as 

long as you save in a format that is capable of retaining it, so OGG 

and MP3 are good, but many WAV files will lose it.

We’re finally ready to render the first track as an MP3. Choose 

File > Export (in earlier versions of Audacity, the action is File > 

Export MP3). As mentioned above, you may need to do Browse 

For Other Folders to enable the MP3 export options, but once this 

is done, hit the Options button to configure the format. There are 

loads of options here, but it’s usually enough to remember that 

larger numbers in the Quality settings (which is defined in kilobits 

per second) will result in better quality files and bigger file sizes. 

Most people rip at either 128 or 256kbps, and it’s worth 

remembering that, while it’s possible to downsample a file – for 

example, if you wanted to fit more content on to a small MP3 

player, upscaling a 128kbps file to 256kbps won’t add anything to 

the music. You might even decide to make master recordings of 

your tracks with no compression (as WAV files for example) to 

keep as backups, then re-encode to MP3 for playback on a mobile 

device or your computer. When you’re happy with the settings, 

supply a filename, hit OK and watch as the MP3 is encoded to your 

disk, ready for adding to Amarok or some other audio player.

Ripping a large collection of records to your computer can be 

something of a chore – but most people would regard it, like music 

itself, a labour of love. And let’s face it, if you didn’t want to listen to 

these things, you wouldn’t have bought them in the first place. 

Just be ready to realise that the Toni Basil single you bought in a 

fevered rush in 1982 is, in fact, possibly the worst record ever 

made in the history of civilisation. Of course, we can say this, 

because we didn’t buy that record – it was a present. Honest.  LXF

Analogue vs digital

Back in the olden days, all music was 

analogue – that is, it was recorded and 

then encoded on to tape or vinyl as a 

continuous stream of information. If you 

were to look at the sound in an 

oscilloscope – which enables you to 

visualise audio – it would appear as a 

series of curves that get wider as the 

music increases in volume and narrower 

during the quiet bits.

When sound is digitised it is converted 

into a series of discrete samples. The music 

on a CD, for example, is composed 

of 44,100 samples per second, and hence 

is a 44.1kHz sample. Just like images, these 

samples also come in various bit depths – 

CDs are 16-bit, but professional audio 

recording tends to be either 24- or 32-bit. 

The higher the sample and bit rate, the 

closer the sample is to analogue fidelity. Adding metadata (such as the name of the artist) to your 

songs makes them easier to manage as part of a large library.

 As with most 

computer things, 

bigger numbers 

mean better 

quality.
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