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Andy seems to 
have been taking 
his first steps in 
Linux software 
forever, and has 
been interested in 
technology since 
the advent of the 
Dragon 32. 

Still running loads of different instant messaging clients? Don’t know what 
instant messaging is? Let Andy Channelle enhance your life with Pidgin.

First Steps Beginner-level tutorials 
for users dipping their toes into Linux

Last month We got the best out of the Dolphin file manager and KDE 4.

E
ven as some migrate their instant messaging (IM) habits to 
Facebook – which is blessedly cross-platform – many 
people still persist with their Yahoo, MSN and Google Talk 

accounts. And if your friends are waiting at the end of these 
networks for a message, it makes sense to be able to send one. 
However, Linux users don’t have to keep a large number of IM 
clients on their computers, as Pidgin can deal with all of the most 
popular chat protocols, meaning you can talk to the whole world 
without stressing your PC’s processor.

Pidgin (www.pidgin.im) is a multi-protocol IM client capable 
of working with everything from AIM and MSN to IRC and 
MySpaceIM. The latest version is 2.5.2, and is available for a 
number of Linux distributions as well as Windows and OS X. In the 

latest version of Ubuntu (Intrepid Ibex), this version is available via 
the Synaptic package manager, and packages will also it will also 
be available for most other common distributions.

This tutorial will work with most recent versions of Pidgin 
(everything after 2.4) and we’ll assume that you have the software 
installed and have a working internet connection, preferably 
broadband. The application is likely to be housed under the 
Internet section of your applications menu.

On first run, a wizard will launch to enable you to configure 
your first account. On the first screen, select Add to create a new 
account; this will launch the configuration screen. What you see on 
here will depend upon which protocol/service you select from the 
first drop-down list. For example, if you select AIM there will be 
options for a username and password only, but if Google Talk is 
selected (which is where we’re going) a few more options are 
available. In this case, we’ll need to provide a username, password, 
a domain and a Resource name.

It’s good to talk
When using Google Talk, the username should be every part of 
your Google account name before the @ symbol, and the domain 
section would be everything after the @. If you’re using an account 
that doesn’t have a Google email account associated with it, use 
gmail.com for the domain. If you’re using an older version of Pidgin, 
you may find that there’s no Google Talk option. In this case, select 
XMPP from the protocol list then go into the Advanced tab and set 
Connect Port to 5222 and Connect Server to talk.google.com.

The Resource can be left with the default ‘Home’ setting and, 
depending on your security needs, the password can be added to 
the appropriate space. Leaving the password space blank will 
mean you’re asked to provide the password every time you 
connect, which is the best option if you’re in a shared environment 
and other people might abuse your IM account.

The Local Alias section, which is available in all accounts, 
defines how you’re seen on your own screen (ie ‘Eddie’ or ‘Me’), 
but will not effect how others see your screen name. Finally, select 
the option for mail notifications if you’d like a visual sign when an 
email arrives at your Gmail account. 

It’s also possible to set a ‘Buddy’ icon specifically for this 
account. When selecting a buddy icon, choose something small 
and uncomplicated that won’t look silly replicated a hundred times 
on a long conversation thread.

Once all the detail has been added to the sections, click the 
Save button. The dialog box will disappear and the Buddy list for 
this particular account will appear on the desktop. Pidgin will 
extract information from your account and any contacts who are 
online will appear in the list alongside their own Buddy icons.

If no contact names appear, it may be that no-one on your list 
is online. Select the Buddies menu option and choose Show > 
Offline Buddies to get a list of everyone associated with that 

 Pidgin can 
speak in all of the 
currently popular 
IM protocols, which 
means no more 
app swapping.
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When chatting, 
select Conversation 
> Send File to send 
your buddy a picture, 
MP3 or other file.

Quick
tip

t     messaging

If you missed last issue Call 0870 837 4773 or +44 1858 438795.

account. When you’ve found someone who’s online you can 
double-click on the contact’s name to launch a chat session. A 
new window will appear divided into two sections. At the top is the 
conversation thread, where each message will appear, and at the 
bottom is the chat window where you type in messages before 
hitting the Return key to send the message.

Once you’ve finished a conversation, simply close down the 
main window so only the Buddy List is available. If you’ve been 
discussing some important issues and you’d like a record of the 
conversation, select Conversation > Save As to save a text file of 
the thread, which can then be opened up in any text editor.

Status anxiety
You can add new accounts to the software by using the Accounts 
> Manage Accounts menu or pressing Ctrl+A and following the 
procedure above, but with the appropriate credentials for other 
sites. All active accounts will appear in the Buddy List window and 
contacts associated with each account can be viewed or hidden 
by clicking the disclosure icon next to each account name.

Just as important as knowing who is available is letting other 
know your availability. By default, you’ll be listed as ‘Available’, 
which lets your contacts know you’re waiting for contact. Use the 
drop-down list at the bottom of the Buddy List window to select 
from a selection of pre-made status options such as Chatty or 
Away. The Invisible option allows you to stay connected to your 
network, and hence available for chats, but invisible to other users. 

At the bottom of the status options is a New Status entry, 
which can be used to create bespoke status options (Gone 
Dancing, Sleeping, etc) which can then be selected from the list. To 
do this, select the New Status option, then provide the text that 
will appear in the list, an icon (from the Available, Away, Do Not 
Disturb, etc selection) and a message to go alongside the status. 
Then click on Save to add the option to the list, or Save And Use to 
make it your current status. Contacts will then see this next to 
your name in their own Buddy lists. If you’re using a recent version 
of Gnome, this status can also be set from the system tray (in the 
top-right of the screen) and, in the latest Ubuntu, from the 
Username system tray object, which is also used to log out and 
shut down the computer.

Pidgin + Facebook?
While Pidgin ships with a number of IM protocols, its plugin system 
makes it possible for developers to add more options. One of the 
most popular plugins at the moment is the Facebook chat option, 
which enables users to chat with Facebook friends without going 
to Facebook. The plugin is available from http://code.google.
com/p/pidgin-facebookchat as a Deb a tarball or a Windows 
EXE file, and installation merely involves double-clicking the file, 
following instructions and then restarting Pidgin.

Now when you go to the Manage Accounts option and select 
Add, Facebook Chat will be available in the list of supported 
protocols. This can be selected and configured with your email 
address and password, and then should allow you to chat to your 
Facebook friends. As a bonus, there is also an option that will link 
your Pidgin status to Facebook, meaning you can update your 
Facebook status without having to leave your conversations.

 You can switch accounts on and off in Pidgin using the 
Manage Accounts option.

 Bespoke status messages can be piped to your Facebook 
account with the help of the Facebook plugin.

 Adjust the 
emoticons to suit 
your mood. There 
are hundreds of 
themes available 
on the internet.
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To get a good idea 
of how things look, 
do File > Print 
Preview. The result 
may take a while, 
but it’s worth it.

Quick
tip

rotation. By default, this is set to the top-left of the object, but it’s 
easier to reset it to the centre.

There’s also a second rotation option, which can be used to 
dynamically rotate an object, on the toolbar next to the zoom 
option. Select this and the resize handles on a selected object will 
become rotate handles. Click, drag and note that the rotation 
value in the properties inspector changes with your movement.

Once you’ve finished dragging stuff around, there are various 
elements that can be edited using the Properties inspector. For 
instance, if you have a piece of text on the page, select it using the 
text selection tool from the toolbar (it has a large A on it) and then 
select the Text tab from the Properties inspector. In here you’ll find 
options to set the font, font size and leading (the space between 
lines of text), colour, alignment (left, right, centre), the number of 
columns for the text to flow down and many other characteristics. 

Page setup
The top page of our pair will be the front and back of a folded card, 
and the second page is the inside. To make this work, we’ll be 
creating content on the right side of both pages so that when 
they’re printed back to back, cut and folded, the elements of the 
card will all appear in the appropriate places. Modifying the project 
to create a double-sided invite would involve making sure the front 
and back elements coincide when printed, so parts on the left of 
the first page would need a counterpart on the right of the second, 
and vice versa. In addition to this, we’ve set the margins at 10mm 
all around and used a series of guides to mark out the same 
margins for the ‘logical spaces’ for the cards. We could have 
defined the page itself as a landscape A5 (or even a pair of A6 
pages) and then positioned these as part of the print process, but 
at this stage it’s easier to create a single A4 page and divide it up. 
This also saves paper when it comes to the final print.

The real beauty of creating cards in this way is that they can be 
as simple, extravagant, personal or generic as you like; you’re in 
complete control. 

Never miss another issue Subscribe to the #1 source for Linux on page 52.

S
cribus is a free, open source desktop publishing package 
that is the perfect application for those moments when 
OpenOffice.org just doesn’t cut it in the design stakes. In 

this short project we’re going to create a card that could be 
printed out and sent off around the world for birthdays, Christmas 
or any occasion. In fact, with a little modification, this design could 
be turned into an invitation, ticket, gift tag or flyer, making it an 
ideal starting point for tons of projects.

Working in Scribus is quite simple, though the sheer number of 
options available can seem a little overwhelming. The user 
interface is easily split into the toolbars and menus, a Properties 
inspector and the work area. The toolbars and menus are where 
you select things to add to the page. For example, under the Insert 
menu you’ll find the two tools we’ll use most often here: the Text 
and Image Frame tools. Selecting one of these (or their toolbar 
equivalent) enables us to define a space on the page that is going 
to contain, respectively, a piece of text or a picture. The power of 
this type of software is that once an area has been defined and 
filled, it can be re-edited quite easily just by dragging stuff around 
with the mouse.

Object manipulation
Use the Select Item tool (the black arrow) to move and resize 
objects on the page. When you click on an object such as an image 
or text frame, handles will appear on the edges and corners of the 
box, and these can be used to resize or reshape the object to fit the 
page. You can also use the Properties inspector to change various 
elements of the frame: look under the Shape section to see a 
corner radius option, which can be used to add rounded corners to 
any type of frame; or look under X, Y, Z to resize and reposition the 
object using numerical values rather than the mouse.

You’ll also find in this section the always-useful Rotation value, 
which can be used to put text or pictures at jaunty angles. Below 
the rotation value is an icon which defines the base point for the 

 In the final card, we’ve added a border to the main image, 
dropped in a robin and given the main text a drop shadow.

 Scribus allows 
objects to be 
rotated with 
the mouse or 
numerically via 
the Properties 
inspector.

Scribus: Mark      y
Cheap printers and free software mean no more expensive card buying. Woot! 
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Next month Take Scribus to the next level and simple photo fixes with F-Spot.

1  Choose paper size
Select File > New to launch the page definition 
window. Select A4 as the page size and then, 
under options, select 2 for the number of pages 
and change the default measurement unit to 
millimetres (mm). Set the page margins to 10mm 
all round and ensure ‘Single Page’ is selected 
from the list on the left of the window. Hit OK to 
create the page and dismiss this window.

4  Add text
Select Insert > Text Frame and then draw a new 
frame above one section of the image. Choose a 
part of the image that is relatively consistent in 
colour, so the text can be made to show up well. 
Once the frame is drawn, select the Text icon (it’s 
the ninth one in from the right on the toolbar), 
select the text frame and type out your message 
in the default font.

2  Set the guides
Click inside the horizontal ruler (at the top of the 
screen) and drag out three guides to the following 
locations: 138mm, 148mm and 158mm. Do the 
same on the vertical rulers and drag guides out to 
95mm, 105mm and 115mm. This divides the page 
up into four sections. Once printed, we could cut 
along the vertical centre of the page and fold 
along the horizontal to create two cards.

5  Find a font…
Select the text, then choose the Text option from 
the Properties box. Select a different font from 
the list, then adjust the size using the Font Size 
option. Now go into the second page and create a 
text box on the right-hand portion of the page and 
add a seasonal message and format the text in 
the appropriate way.

3  Add a main image
Do Insert > Image Frame and draw a new image 
frame covering one of the right-hand sections 
following the guides. With this frame selected, do 
File > Import > Get Image and navigate to a 
suitable picture. We have a Creative Commons 
image from Flickr by WhiteTiger8370. Select 
Image from the Properties box and scale the 
image using the X and Y values. They are linked by 
default, so the image will retain its proportions.

6  And we’re done!
We’ve added rounded corners using the Shape 
section, and a border using Line and Line Colour 
(all in the Properties box), and then copied 
everything to the lower section (marquee select 
then copy/paste). Finally, go into File > Print and 
print the document on to some decent card. Now 
cut them up, shove them in an envelope and send 
them to your lucky loved ones.  LXF

      your cards
Step by step: Make a greetings card in Scribus
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